Support » Plugins and Hacks » [Resolved] Color of background – no proxy.php

[Resolved] Color of background – no proxy.php

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author k3davis


    Hi esbenh,

    Yes, in GDE 2.5 there is an actual color picker and no hacking of the files is required anymore.

    Ensure you have selected a profile that uses the “Enhanced Viewer” and you should see an appearance option called “Page Area Background Color”. It’s visible in the screenshot here for reference.

    Hope this helps!


    Hi Kevin

    Thanks for the super fast reply! Unfortunately it does not work for me using the dark theme and customizing colors in the Enhanced Viewer settings. I am able to remove the toolbar, but neither colors nor borders can be changed. I am running off a local install, but that should not mean anything with regard to the color issue, right?

    Thanks for helping out!

    Plugin Author k3davis


    Hi esbenh,

    The dark theme uses a custom CSS file. If you want to keep the full customization of the dark theme and still change the background color, you’ll have to make a copy of that dark CSS file and change it to reflect the new colors, save it somewhere on your site (outside the plugins folder, otherwise the settings will be lost on upgrade), and enter that URL in the “Custom CSS” option. When you use a CSS file, it overrides the color picker options because it allows you to change EVERYTHING, even a number of colors for which there are no settings.

    If you only want to change the background color, here’s probably the easiest way to do so:

    * Add a new profile, based on the “Default” profile. Call it anything – “blue-theme” or whatever.

    * After creating the new profile you’re taken to the profile edit page. Now change the viewer mode to Enhanced, and the additional options become visible.

    * Change the Page Area Background Color setting to the color you want, and save the profile.

    * In your shortcode, make sure you select the profile you just created, either by its name or its ID number.

    If you want this to apply to all documents, you can just change the default profile as above without creating a new profile. Then you don’t need to specify a profile in your shortcode at all to use it.

    Let me know if you need more help. Thanks!


    Thanks again for the swift reply! I will look into it asap.

    Have a great new year!


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Color of background – no proxy.php’ is closed to new replies.