• Resolved east1023

    (@east1023)


    Since the update of Collapse-O-Matic from version 1.8.5.5 to 1.8.5.6 (20/04/24) my site has problems. The original code was:

    [expand title=”Art in the Drawing Room” rel=”Group-highlander” targclass=”small”]Click here for Group page …….

    This now seems to fail to process the expand tag correctly and displays as: < class=”collapseomatic ” id=”id662655918cb97″ rel=”Group-highlander” tabindex=”0″ title=”Art in the Drawing Room” >Art in the Drawing RoomClick here for Group page ……

    As a temporary fix I have reverted back to version 1.8.5.5

    I’m using WordPress 6.5.2, PHP 8.1.27 and Theme OceanWP (Child).

    Any help would be appreciated.

    Thanks

    Ed Dee

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author twinpictures

    (@twinpictures)

    Interesting.
    In the options page, what do you have set at the default tag element?

    Thread Starter east1023

    (@east1023)

    Thanks for the reply. Original settings:

    Style: light

    Tag attribute: h7

    Tabindex Attribute: 0

    Plugin Author twinpictures

    (@twinpictures)

    h7, that’s the issue.
    The HTML specification defines six headings
    h1 – h6… is it an issue for you to use h6?
    technically, HTML will support any kind of tag you want to use, but for security reasons, version 1.8.5.6 only supports the h1 – h6 header elements.

    Thread Starter east1023

    (@east1023)

    Thanks. I inherited this site so am uncertain as to the rationale behind the h7. However, changing the tag to h6 inserts a blank line after each header line. This is no a killer but it does make things look a little untidy.

    I have to go out for tonight (uk time) so if you reply to this message it will be tomorrow when I reply.

    Thanks again

    Regards

    Ed Dee

    Plugin Author twinpictures

    (@twinpictures)

    OK. so it is possible to modify the CSS for all h6 elements to not have that gap, padding, margin… or blank line as you described it.

    The question is are there other h6 elements being used throughout the site, and if so, this might become a headache. Sit tight, we’ll think of something to get around this issue.

    Plugin Author twinpictures

    (@twinpictures)

    version 1.8.5.7 resolves this issue by including any tag that is defined as the default tag attribute in the allowable tags.

    Thread Starter east1023

    (@east1023)

    Very many thanks for fixing that. I’m impressed that you responded to my support request so quickly, immediately identifying the fault and then fixing it. Great.

    Regards

    Ed Dee

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.