Support » Fixing WordPress » COLGROUP still not recognized; spurious BR added

  • As seen on a previous entry where the unhelpful advice was to discuss it on a mailing list:

    colgroup cannot be used in a WP blog entry. The parser places spurious br tags at the end of each instance, thereby causing validation errors.

    That remains true even if all whitespace is deleted from a range beginning immediately before and ending immediately after the colgroup. I don’t think any enclosed col elements cause problems.

    Was true in 1.x and is true in 2.01 alpha.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Gosh, the referral to the programmers’ lists wasn’t unhelpful at all really. That’s how this sort of thing gets added sometimes to the program. Had the OP on the linked thread posted to the list, perhaps it would be included in this release.

    What’s it good for, btw? I don’t know that I’ve ever run across those tags….

    I’ve just tested this and you’re correct Joe. I’ve raised it to the wp-hackers list as I noticed that an earlier patch had been made which was supposed to have addressed this issue (

    What’s it good for, btw?

    As the name suggests, it’s for the grouping of columns. One use would be to cleanly style a set of columns e.g. with the following markup, you could apply a common style to two columns with one class:

    <colgroup span="2" class="importantColumns"></colgroup>

    Oh. If one used tables, you mean.

    If one used tables, you mean.

    For tabular data, of course. But we digress:)

    No, not really. Because there are times of course when that would definitely be useful in tabular data. My blogs don’t have that need, but there are surely people who use actuarial tables and so on in their postings.

    So IF this particular thing worked (and since you’ve now posted it to trac, perhaps it will eventually get fixed), it might help out some folks who’ve had problems posting tabular data to their blogs.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘COLGROUP still not recognized; spurious BR added’ is closed to new replies.