Support » Plugin: Bitcoin and Altcoin Wallets » Coin balance, withraw, transactions, blanck

  • Resolved UgoDimma

    (@lovecoinz)



    I tried to enable frontend feature by adding the following codes in a page
    [wallets_balance] [wallets_transfer] but it all shows an input box, yet nothing can be put in any of them as shown in the image bellow…
    The image
    All the space you are seeing on the image, none of them is clickable, in that case, you cannot even add information there.
    I tried both simple code method and widget method as you can see also on the image, and they are both the same.
    Am using external adapter, coinpayment system on my site.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author dashed-slug.net

    (@dashedslug)

    Hi,

    There are several reasons why this would happen. I have assembled a list of reasons in the troubleshooting section of the manual under the title “I do not see the UI elements in the frontend.”, so have a look there and if you can’t figure it out let me know again.

    regards

    Thank you for your response.

    I went from number 1 to 4 under the title, “I do not see thw UI elements in feontwnd”, and they are all i tact.

    I logged in as an admin primarily as am setting the plugin when I discovered this issue. I then give another user level, customer The required capability to have wallet, transfer, withdraw access and log in with another user account with that capability, still yet, the same issue.

    I cross checked the code I entered, and they are all correct. Nevertheless, the issue also affects the widgets giving the same result.

    Plugin Author dashed-slug.net

    (@dashedslug)

    OK, please check your browser’s JavaScript console for any errors (not warnings). If any script on your page has caused an errors and has halted execution of JavaScript scripts, then this would cause the UIs to not load.

    Also check the network tab for the XHR connections to the plugin’s JSON API. If these requests fail for any reason, the UIs would not load. Perhaps you have configured your security plugin to not allow API requests?

    UgoDimma

    (@lovecoinz)

    Hey

    Thanks for your response. I have been on it for long. But unfortunate, no result yet.

    I disabled my security plugin (Wordfence), deactivate Itheme security as well.

    Also check the network tab for the XHR connections to the plugin’s JSON API.

    Can you five me some insight on how to check this one.

    You can also take a look at the Site here In case you need to have a look.

    UgoDimma

    (@lovecoinz)

    Here is the exact page where I added the codes mannualy –Users wallet
    At any page of the site, the widget is also there to see.

    UgoDimma

    (@lovecoinz)

    In addition, I have tasted this plugin on two different sites making it three in total, though all on the same server. But still getting the same and exact result.

    Just tasted it on a newly set up site, yet, no positive result.

    Plugin Author dashed-slug.net

    (@dashedslug)

    Hello,

    I quickly signed up and had a look. The get_coins_info JSON API does not return any coins, therefore this is why the UIs do not show.

    You need to have at least one coin adapter that is in status “Responding”. From the docs it’s troubleshooting tip number 4.

    > 4. Check that at least one coin adapter is online. Go to WalletsAdapters and check the status column of each adapter.

    Can you verify that you have coin adapters in a responding state?

    UgoDimma

    (@lovecoinz)

    Yea.

    I have coin adapter responding as you can see in this Image
    It is a screenshot of the admin section of Wallets -> adapters

    Plugin Author dashed-slug.net

    (@dashedslug)

    Yes, I see. I will do some tests on my side and let you know.

    Plugin Author dashed-slug.net

    (@dashedslug)

    OK this is a strange error indeed.

    Going through the code line by line there are not that many things that could cause this. Your issue is that you have some adapters working, and yet the call

    https://tony.ugochukwu.org/user-wallets/?__wallets_action=get_coins_info

    returns success with an empty array of coins.

    I can only think of one way to debug this. Can you enable logging and check for a line that starts with “Could not get info about coin with symbol”?

    Instructions for enabling logging are here: https://codex.wordpress.org/Debugging_in_WordPress

    You need these in your wp-config.php:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Your logs will be written to wp-content/debug.php.

    Don’t forget to remove these afterwords from wp-config.php.

    Let me know what you find.

    UgoDimma

    (@lovecoinz)

    The capabilities are well granted per my need as seen in this Image.
    But the issue is the same irrespective of the capability of the loged in user.

    Plugin Author dashed-slug.net

    (@dashedslug)

    Yes, I believe you, this problem would not be caused by incorrect capabilities.

    It is a rare error that I have not seen before, the only way to debug it is as I detailed above. I cannot reproduce it on my side.

    UgoDimma

    (@lovecoinz)

    I took a look, and bellow is the error report related to this plugin.

    [21-Jan-2018 11:52:58 UTC] Could not get info about coin with symbol BTC: The Bitcoin on CoinPayments adapter failed on get_new_address(): The API call returned error: This API Key does hot have permission to use that command
    [21-Jan-2018 11:52:58 UTC] Could not get info about coin with symbol BCH: The Bitcoin Cash on CoinPayments adapter failed on get_new_address(): The API call returned error: This API Key does hot have permission to use that command
    [21-Jan-2018 11:52:58 UTC] Could not get info about coin with symbol ETH: The Ether on CoinPayments adapter failed on get_new_address(): The API call returned error: This API Key does hot have permission to use that command

    By the look, it is a matter of permission, but which permiseion does it requires now?

    Plugin Author dashed-slug.net

    (@dashedslug)

    OK thanks for reporting this.

    I did another test, only with the permissions that are listed on the adapter page.

    The adapter correctly produces new addresses when only these permissions are checked.

    Therefore I would recommend that you check the following:

    1. Make sure that the necessary permissions are checked on your API key.
    2. Make sure that you are using the API key that you are editing. If you have created multiple keys, is it possible that you have entered a different key in the coin adapter settings?

    This should solve your problem.

    UgoDimma

    (@lovecoinz)

    In the configuration settings of the coinpayment, there is no column for API Key other than Public Key, Private Key, Merchant ID and IPN Secret.

    Where do I have to put API Key, or is there a universal one hard coded into the plugin?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Coin balance, withraw, transactions, blanck’ is closed to new replies.