WordPress.org

Support

Support » Plugins and Hacks » [Resolved] CodePeople Post Map not showing

[Resolved] CodePeople Post Map not showing

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author codepeople

    @codepeople

    Hi,

    I’m sorry for delay, I’ve not received the notification of your entry in the product’s forum.

    I’ve checked your webpage, and saw that you are using another plugin. One time again, my apologize for delay.

    Hi,

    I do have the same problem. Installed the plugin, added a POI and the code, but nothing happened….
    I tried it on this Post: http://thewildangle.com/2013/10/clouds-over-boesmanskloof/

    Thanks,
    henning

    Plugin Author codepeople

    @codepeople

    Hi,

    Your website is not loading the javascript and styles files, required by our plugin, please tries the following steps:

    1. Open the codepeople-post-map.php file, located in “/wp-content/plugins/codepeople-post-map/codepeople-post-map.php”, in the text editor your choice.

    2. Paste the following line of code at the end of file (specifically the line above to “?>” )

    add_action(‘wp_enqueue_scripts’, array(&$cpm_obj, ‘load_resources’), 99);

    Let me know the results, please.

    Awesome! Works perfectly! Thanks a lot!

    But I have another question. When I put my marker on the map and press “verify”, tha marker does not stay on my position, it randomly jumps to the next bigger “town/spot/place”. Can I bypass that (specially when I want to place the marker in “middle of nowhere”)?

    Plugin Author codepeople

    @codepeople

    Hi,

    That occur because Google doesn’t identify the address typed, and corrects the point’s location to the nearest place that can identify. So, to corrects the point’s location, follow the steps, below:

    1. Enter the points address and press the “Verify” button.

    2. On preview map drag the pointer to the correct location, the action corrects the values of latitude and longitude of point, and then “WITHOUT PRESSING AGAIN THE VERIFY BUTTON”

    3. Updates the page (or post) data.

    That’s all.

    Perfect! You guys are great!

    Hi the map won’t display at all.

    I used the following on my template page:
    <?php echo do_shortcode('[codepeople-post-map cat=838 width="100%" height="600"]'); ?>

    Also tried:
    <?php echo do_shortcode('[codepeople-post-map]'); ?>

    When viewing the code on my page I get

    <div id="cpm_itc6IZ" class="cpm-map" style="width: 100%; height: 600px; clear: both; overflow: hidden; margin: 0px auto; display: none;"></div>

    The js is

    var cpm_language = {"lng":"en"};var cpm_global = cpm_global || {};
    cpm_global['cpm_itc6IZ'] = {};
    cpm_global['cpm_itc6IZ']['zoom'] = 10;
    cpm_global['cpm_itc6IZ']['dynamic_zoom'] = true;
    cpm_global['cpm_itc6IZ']['markers'] = new Array();
    cpm_global['cpm_itc6IZ']['display'] = 'map';
    cpm_global['cpm_itc6IZ']['highlight_class'] = 'cpm_highlight';
    cpm_global['cpm_itc6IZ']['highlight'] = false;
    cpm_global['cpm_itc6IZ']['type'] = 'ROADMAP';
    cpm_global['cpm_itc6IZ']['show_window'] = true;
    cpm_global['cpm_itc6IZ']['show_default'] = false;
    cpm_global['cpm_itc6IZ']['mousewheel'] = true;
    cpm_global['cpm_itc6IZ']['zoompancontrol'] = true;
    cpm_global['cpm_itc6IZ']['typecontrol'] = true;

    http://www.the-rosy-lee.com/type-map/

    Any ideas? Thanks in advance.

    Plugin Author codepeople

    @codepeople

    Hi,

    First, the “cat” attribute (for categories 😉 ), is available only in the premium version of plugin.

    Second, if you insert the shortcode in template (without the “cat” attribute), the map will be displayed only if the page that use the template file include some point.

    For example, suppose you’ve inserted the shortcode in the homepage’s template, and you have configured your WordPress to display the newest posts on homepage. In this case the map will be displayed only if at least an post displayed on homepage has associated a point.

    Best regards.

    Thank you that works.

    I have another question. The map point description section has an option to attach an image to the point although when I click upload images and find the desired image and click insert into post nothing happens? Is this feature for the premium version only as well?

    Plugin Author codepeople

    @codepeople

    Hi,

    The association of an images to a point, is available in all versions of plugin.

    After select the image from the gallery, the image’s location is entered in the corresponding box. You only should save then the point’s data, and the image will be displayed in the infowindow associated to the point.

    Ok excellent as this feature is quite important for what I want to achieve although the selected image from the library is not being entered in the corresponding box, it remains blank?? Any ideas?

    Also can I change the colour scheme of the map?

    Thanks

    Plugin Author codepeople

    @codepeople

    Hi,

    Maybe there is a plugin in your website that is intercepting the images selection, and its insertion in the corresponding box. Please, try inserting the absolute URL (http://…) of image, directly in the field. I can’t detect the issue, from your public website.

    About the colour scheme of the map, I can give you some tips, but if you requires more specific information, you should contact us through our support page:

    To stylize the map should create the styles definition, like follow:

    http://wordpress.dwbooster.com/support

    var map_styles = [
    {
    stylers: [
    { hue: “#00ffe6” },
    { saturation: -20 }
    ]
    },{
    featureType: “road”,
    elementType: “geometry”,
    stylers: [
    { lightness: 100 },
    { visibility: “simplified” }
    ]
    },{
    featureType: “road”,
    elementType: “labels”,
    stylers: [
    { visibility: “off” }
    ]
    }
    ];

    and then apply the styles to the map, for example:

    map.setOptions({styles: map_styles});

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] CodePeople Post Map not showing’ is closed to new replies.