Support » Plugin: CodeColorer » codecolorer, php 5.3 and “Invalid opcode”

  • Resolved richlv

    (@richlv)


    upgraded to the latest plugin version on a site that’s hosted on php 5.3.27.

    unfortunately, it now fails with :
    Fatal error: Invalid opcode 153/1/8. in /.../wp-content/plugins/codecolorer/codecolorer-core.php on line 54

    what is causing it and how to resolve ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Dmytro Shteflyuk

    (@kpumuk)

    Hi,

    PHP 5.3 ended its life in 2014: http://php.net/eol.php
    The latest version of CodeColorer only supports 5.5+, if you want to continue using PHP 5.3, please downgrade CodeColorer to 0.9.9: https://downloads.wordpress.org/plugin/codecolorer.0.9.9.zip

    I would recommend upgrading though because 5.3 does not receive any security or performance updates, and your server might be exposed to various vulnerabilities.

    thank you for the quick response. in this case, it’s a hosted instance, not much control over it (and vendors like rhel will provide support for a while still).

    thank you for the clarification on the last version to support php 5.3 – will find out whether the hosting company plans to upgrade, use the old version if not 🙂

    Plugin Author Dmytro Shteflyuk

    (@kpumuk)

    There are no functional differences between 0.9.9 and 0.9.11 (except for couple additional color themes), the updates are mostly to handle the PHP version upgrades.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘codecolorer, php 5.3 and “Invalid opcode”’ is closed to new replies.