WordPress.org

Support

Support » How-To and Troubleshooting » Code versus Visual

Code versus Visual

  • Hi there

    OK, so I’m not at all tech-savvy, so I’d LOVE whomever helps me fix this problem that is driving me NUTS.

    When I go to edit a certain page of my site it comes up in two different versions: either CODE or as VISUAL.

    Now, I’d love to work in the visual format as it’s easier for me, but if I do this and save my work, the page looks all scrambled and out of sync. It basically just doesn’t work.

    So, I go to work in code, which I have been doing since I started using this site, (the ‘visual’ element just appeared suddenly one day – I’d never seen it before) and when I work in code every time I save and go back into edit again, the code has been squished all together! So then I have to go in and separate every single item…

    You can imagine how tedious this is.

    Please help me! I have no idea why this visual stuff has appeared and why when I try to work in code it doesn’t just save the way that I put it in the first place!

    Thanks sooooooo much.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You MUST turn off the visual animal in admin > Users > Your profile. Otherwise (when only switching) it is always ON, which means during the Save process the visual is in effect… screwing up all the handmade code because the wysiwyg/visual is not supposed to “know” anything about code. It expects only plain text, nothing else.

    I never turn on the visual and I use quite a bit of foramtting and other html code in my posts – yet WP never ever “scrambles” my code.

    This has helped me slightly, I’ve turned visual off and now can insert images, smilies etc. I’d gone in to edit and create some pages after not using the system for some time and was rather befuddled as to why I was having problems.

    Why does visual not work for me ? If I drag an image (or smiley) the resulting page just displays the url, if I click the “send to editor” button nothing happens.

    If Visual and Code tabs are showing I can’t switch between them ? or am I missing something here ?

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Code versus Visual’ is closed to new replies.