Support » Plugin: Code Snippets » Code Snippets Plugin fails to install

  • Resolved arthurlaw1

    (@arthurlaw1)


    I am so sorry, I have used this forum I think only once before and did not realise that I had posted on another person’s post.

    When the problem occurred I deactivated all my plugins but the error that I am attaching continued to occur. So I came to the conclusion that it was not another plugin causing the Code Snippets Plugin to fail

    I have the Avada Theme V7.6.1 installed and am not sure if that is causing the problem, however, I activated the WordPress 20222 theme and still had the same problem when trying to activate Code Snippets, which by the way is a wonderful plugin and has always served me well
    I don’t see where I can attach a screenshot of the error message.
    However, below is exactly the message received:

    Version 2.14.3 | By Code Snippets Pro | View details
     This plugin failed to load properly and is paused during recovery mode.
    
    An error of type E_ERROR was caused in line 7 of the file /usr/www/users/advenzqkrq/wp-content/plugins/code-snippets/php/snippet-ops.php(469) : eval()'d code. Error message: Uncaught Error: Call to undefined function images() in /usr/www/users/advenzqkrq/wp-content/plugins/code-snippets/php/snippet-ops.php(469) : eval()'d code:7 Stack trace: #0 /usr/www/users/advenzqkrq/wp-content/plugins/code-snippets/php/snippet-ops.php(469): eval() #1 /usr/www/users/advenzqkrq/wp-content/plugins/code-snippets/php/snippet-ops.php(557): execute_snippet('$args = array(\r...', 6) #2 /usr/www/users/advenzqkrq/wp-includes/class-wp-hook.php(307): execute_active_snippets('') #3 /usr/www/users/advenzqkrq/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #4 /usr/www/users/advenzqkrq/wp-includes/plugin.php(474): WP_Hook->do_action(Array) #5 /usr/www/users/advenzqkrq/wp-settings.php(450): do_action('plugins_loaded') #6 /usr/www/users/advenzqkrq/wp-config.php(96): require_once('/usr/www/users/...') #7 /usr/www/users/advenzqkrq/wp-load.php(50): require_once('/usr/www/users/...') #8 /usr/www/users/advenzqkrq/wp-admin/admin.php(34): require_once('/usr/www/users/...') #9 /usr/www/users/advenzqkrq/wp-admin/plugins.php(10): require_once('/usr/www/users/...') #10 {main} thrown

    Please let me know if you require login detail information to my WP_Admin
    Best regards
    Arthur

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Shea Bunge

    (@bungeshea)

    Hi Arthur,

    That’s absolutely fine, not a huge deal if you accidentally post on an existing thread. It just makes it easier to answer each person if they have their own post I can reply to.

    As for your issue, the problem is that the snippet code you already have on this site is now broken for whatever reason (likely it was relying on a plugin or theme you no longer have activated), and now when you switch on the plugin that code is trying to run again.

    The solution is to enable safe mode before activating the plugin, which will prevent any of your snippets from executing. Then once the plugin is active, you can deactivate or remove the snippets causing issues and use the plugin as normal.

    We have a page that details how you can turn safe mode on for your site here: https://help.codesnippets.pro/article/12-safe-mode

    Hopefully this helps!

    Thread Starter arthurlaw1

    (@arthurlaw1)

    Hi Shea
    Thank you for your prompt response, I tried to resolve using safe mode and activated your
    Code Snippets Plugin, which activated successfully.

    I then deactivated all plugins and exited safe mode.

    On attempting to Activate any of the installed plugins I continue to get the error as reported previously.

    Just to clarify the following:

    This site is a new site that I have just built and Code Snippets was the plugin installed and activated after I had installed all plugins I required. So, I had not added any snippets at all. The error occurred on installing and activating the Code Snippets plugin, so no Snippets were added to the plugin at all.
    I hope this helps and I trust I followed the instructions provided by you correctly. Once again regret troubling you I know you guys are extremely busy and do a lot for the Word Press Community without compensation.
    Best regards
    Arthur

    Plugin Author Shea Bunge

    (@bungeshea)

    If you are experiencing the issue while Code Snippets is disabled then it must be related to a different plugin (or the active theme) on your site.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.