• Resolved CC05

    (@ayano-hisa-photo)


    Hello,

    I am trying to setup AdSense for my website now. I think I successfully setup Site Kit yesterday, and went to Adsense account and checked “I have pasted the code into my site” and clicked DONE, but it says the code is missing.

    I didn’t even receive an email to connect the site to AdSense, like I did with other site before.

    Can anyone please help please?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • @ayano-hisa-photo thanks for reaching out!

    When I check the source code of your site, I see Site Kit’s Adsense snippet. So that messaging is unusual.

    One thing I notice is that although your site is serving over the https:// protocol, there is mixed content and per the info in the site’s rest route, it appears there are different protocols for the values in the WordPress settings under Settings > General. I don’t know if this is intentional, but mixed protocols can impact setup in some cases.

    Feel free to send your Site Health information here or through this form. We can then check what info Site Kit has regarding the connection with Adsense.

    Thread Starter CC05

    (@ayano-hisa-photo)

    Hello Renee,

    Thank you for replying back!

    Nothing is intentional.. I’m actually trying to solve that problem of mixed content.

    What you mentioned was right. I went to the Setting > General and it was still http instead of https. So I corrected it to https, but the mixed content issue is still there.

    It seems like a Slider widget by Elementor is causing the mixed content issue. If I remove the slider on top of my HOME page, it eliminates the issue. I contacted Elementor to ask about it.

    I also submitted the Site Health information through the form.

    Thanks!

    Thread Starter CC05

    (@ayano-hisa-photo)

    By the way, I still saw the “Code is Missing”, but I clicked proceed without checking option, and now the Adsense says it’s review my site. I guess it’ll be disapproved unless I fix the mixed content issue… Still waiting for Elementor to reply back.

    Thanks!

    Thread Starter CC05

    (@ayano-hisa-photo)

    Hello,

    I just checked Site Kit and now it says Data Error, Missing Delegation Consent, on both Search Console and Analytics. Do you know why?

    Thanks!

    Thread Starter CC05

    (@ayano-hisa-photo)

    Hello, I reconnected the Search Console and Analytics and now they are connected correctly, so please ignore my last message.

    And now I think I know why AdSense is not working… Adsense actually uses my other gmail account. I wanted to use my regular gmail account but it didn’t let me change the location from my home country. The address field had “prefecture” and “postal code”, which doesn’t exist in USA, and it didn’t let me create an account for USA. This is probably because I tried to create AdSense account before, and the country setting stayed the same for the account. So, I made another gmail account and I used the new account for AdSense.

    For Search Console, Analytics, Optimize and Tag Manager, I use my regular gmail account.

    So, this could be the reason why AdSense is not working in my WP site.

    Is there any way I can use Google products with 2 different accounts in 1 WP Site Kit? Or do you know any way to change the country setting on AdSense in my regular gmail account?

    Thanks!

    @ayano-hisa-photo thanks for the updates! We provide support on weekdays only so sorry for the delay in the reply. I’m glad you got most of the issues encountered sorted.

    Is there any way I can use Google products with 2 different accounts in 1 WP Site Kit? Or do you know any way to change the country setting on AdSense in my regular gmail account?

    With Site Kit, you should only use one Google Account to connect the products unless there are multiple admin users with their own Google accounts and the appropriate permissions to the accounts/ properties for the products you’re connecting- Analytics, Adsense, etc.

    I currently see Site Kit’s Adsense code on the the site. In regards to updating the country, you may find this Adsense article helpful or you can reach out to the experts and the Adsense Help Center for more assistance.

    Thread Starter CC05

    (@ayano-hisa-photo)

    Hi Renee,

    No worries, thanks for replying back.

    I cannot even change the payment address because my account is not setup yet. I’m at the process of setting it up but it only allows me to choose prefecture and postal code as part of my address. I need USA states and zip code options. I already contacted Adsense Help center and also Adsense community, but no one was able to solve it. I can’t even cancel it because I haven’t even set it up yet.

    So, I decided to create another gmail account and thought I would be be able to use it for my site only for Adsense. But all other Google products use another gmail account.

    I have not been able to get any help on this. I will make another post in the Google community in the below link.
    https://support.google.com/adsense/thread/60154162?hl=en&authuser=1

    If I cannot solve this issue, can I make another user account with my WP site using another gmail account and connect the Adsense with the new user? I’d rather want to use my regular gmail address for all of them but it doesn’t let me…

    Thanks!

    • This reply was modified 3 years, 10 months ago by CC05.
    Thread Starter CC05

    (@ayano-hisa-photo)

    UPDATE: My AdSense account got approved. However, my Site Kit still says my account is getting ready. So I guess this means they aren’t connecting with each other. Site Kit uses my regular gmail account but AdSense belongs to my other gmail account….

    I hope there is a way to solve this…

    @ayano-hisa-photo thanks for the updates!

    If I cannot solve this issue, can I make another user account with my WP site using another gmail account and connect the Adsense with the new user

    ?

    You can certainly connect another Google account with Site Kit. Just keep in mind it would need to be one Google account per admin user for all the services. So that Google account needs access/ permissions to all the service accounts and properties you connect.

    Thread Starter CC05

    (@ayano-hisa-photo)

    >If I cannot solve this issue, can I make another user account with my WP site using another gmail account and connect the Adsense with the new user

    >>?

    I was referring to “With Site Kit, you should only use one Google Account to connect the products unless there are multiple admin users with their own Google accounts and the appropriate permissions to the accounts/ properties for the products you’re connecting- Analytics, Adsense, etc.”

    So this means if I make another WP user account and connect the other gmail account for AdSense with the new WP user account, I can connect the AdSense to my WP, but I always have to use the new user account to be able to use AdSense? Or maybe I can give permission to my main gmail account to access AdSense once I set it up… I’ll try…

    Thanks.

    @ayano-hisa-photo sounds good! While we’re limited to providing support with Site Kit only, the Adsense Help Center would be best the resource for further Adsense assistance.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Code missing?’ is closed to new replies.