Support » Plugin: jQuery Pin It Button for Images » Code for nopin class

Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author Marcin Skrzypiec

    (@mrsztuczkens)

    Hi karenstl,

    to be honest, the code looks just fine. Could you add the nopin class to an other image in some other post and leave a link to this post here? I will take a look on what might be wrong. Also, please activate debug mode (advanced settings).

    I figured out what was wrong I had two class= instead of just adding the nopin inside the quotes with a space between the items. That’s what happens when you don’t know code. You might want to put an example on your description on the plugin site of how to do this showing people how to add the nopin class to an image’s html. Many of us don’t know html at all.

    Plugin Author Marcin Skrzypiec

    (@mrsztuczkens)

    Done.

    @karenstl Hi.

    Per Pinterest – you can block pinning whole sites or individual images.

    http://help.pinterest.com/en/articles/prevent-pinning-your-site

    For an image – add the nopin attribute

    <img src = “foo.jpg” nopin = “nopin” />

    I had this same problem and fixed it like @karenstl did. I had

    <img class=nopin=”nopin” in my photo code

    I deleted the extra nopin and made it

    <img class=”nopin” and now those images I wanted to not have a pin it button, don’t. Thanks @karenstl! 🙂

    @canadianangelxo

    I can’t imagine how that could possibly work unless you actually defined a class for the function in css. I’d love to see it at work do you have a link?

    @karenstl all you have to do is add the code nopin=”nopin” after the src= portion of the code – and it works.

    < img src=”foo.jpg” nopin=”nopin” / > (No spaces next to brackets)

    The other option is to use Phil Derksen’s plugin “Pinterest Block”.
    It has several options that allow you to block whole sites, categories, tags and individual posts and pages.

    Here ▶ http://wordpress.org/support/plugin/pinterest-block

    @bcr8tive the image I didn’t want to be able to be pinned was the Disclousre image I made at the very bottom of this post.

    NOVICA: Unique Handcrafted Gifts from Around The World

    <img class=”nopin” worked and I didn’t define a class for the function in css.

    The only thing that is in my jQuery Pin It Button For Images Options under Disabled classes is nopin and wp-smiley.

    Thanks for the link…

    As I suspected, it is not working. For all intents and purposes there isn’t a way for it to, unless you found a way to write a function that was called by a class.

    Here’s a screenshot – the red arrow is pointing to the image you want the no pin on –

    http://lrhcreative.com/misc-imgs/screen.jpg

    Hmmm it works for me. My pin button doesn’t show up on that image and when I copy and paste that url into Pinterest it doesn’t show up as an image from that link either.

    @canadianangelxo

    I just showed you the screenshot – I can only suggest testing in more than one browser – the image is showing in the pin window – which demonstrates that the class thing is not working.

    And if you’re referring to a hover pin it – I’m not seeing THAT at all.

    You may want to clear your cache too. Sounds like a local thing.

    I just pinned it

    http://www.pinterest.com/pin/196258496236814232/

    That is very strange! I have tried 3 different browsers, cache has been cleared. I still don’t see that image there.

    so for this image code where do I put the nopin=”nopin”?

    <img src=”http://canadianangelxo.com/wp-content/uploads/2014/06/canadianangelxo-disclosure1.jpg” here alt=”canadianangelxo disclosure” height=”100″ width=”700″ or here>

    <img src="http://canadianangelxo.com/wp-content/uploads/2014/06/canadianangelxo-disclosure1.jpg" nopin="nopin" alt="canadianangelxo disclosure" title="canadianangelxo disclosure" height="100" width="700">

    @canadianangelxo Saw you edited it, reloaded the page, and tested it again. Now when I click the browser pinit, it is NOT showing up so nopin is working BUT you’re pinit hover is also working now, so you still can pin it. That’s going to be a conflict unless you use a normal pinit button.

    @bcr8tive thank you for your help! 🙂 Can you tell me how I disable my featured image thumbnails from showing up when people go to pin a post? For some reason it’s picking up my related posts 150×150 images and also my featured images on each post… http://canadianangelxo.com/

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Code for nopin class’ is closed to new replies.