Support » Plugin: Advanced Classifieds & Directory Pro » Code errors after upgrading to PHP 7.2

  • Code errors after upgrading to PHP 7.2 – I’m not really sure what to make of this but they all seem to have to do with this plugin. Please help because I love this plugin so much! Thanks!

    Deprecated: Function create_function() is deprecated in /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/search/class-acadp-widget-search.php on line 187

    Deprecated: Function create_function() is deprecated in /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/locations/class-acadp-widget-locations.php on line 316

    Deprecated: Function create_function() is deprecated in /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/categories/class-acadp-widget-categories.php on line 321

    Deprecated: Function create_function() is deprecated in /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/listings/class-acadp-widget-listings.php on line 375

    Deprecated: Function create_function() is deprecated in /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/listing-address/class-acadp-widget-listing-address.php on line 158

    Deprecated: Function create_function() is deprecated in /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/listing-contact/class-acadp-widget-listing-contact.php on line 164

    Deprecated: Function create_function() is deprecated in /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/listing-video/class-acadp-widget-listing-video.php on line 154

    Notice: is_author was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /home/agsgerbi/public_html/wp-includes/functions.php on line 4161

    Warning: Cannot modify header information – headers already sent by (output started at /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/search/class-acadp-widget-search.php:187) in /home/agsgerbi/public_html/wp-content/plugins/participants-database/vendor/wp-session-manager/class-wp-session.php on line 142

    Warning: Cannot modify header information – headers already sent by (output started at /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/search/class-acadp-widget-search.php:187) in /home/agsgerbi/public_html/wp-content/plugins/visitors-online/visitors-online.php on line 322

    Warning: Cannot modify header information – headers already sent by (output started at /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/search/class-acadp-widget-search.php:187) in /home/agsgerbi/public_html/wp-admin/includes/misc.php on line 1126

    Warning: Cannot modify header information – headers already sent by (output started at /home/agsgerbi/public_html/wp-content/plugins/advanced-classifieds-and-directory-pro/widgets/search/class-acadp-widget-search.php:187) in /home/agsgerbi/public_html/wp-includes/pluggable.php on line 1219

Viewing 4 replies - 1 through 4 (of 4 total)
  • Do you have the option of specifying PHP 7.1? That seems to be a lot less likely to throw these errors as less stuff is deprecated in that version than in 7.2

    Plugin Author pluginsware

    (@pluginsware)

    Hi,

    We are working on PHP 7.2 compatibility and these issues will be fixed soon.

    Thanks

    Any update on the PHP 7.2 compatibility?

    Thank you

    This is the #1 problem I’ve had with php since it was produced so many years ago. Function Bloat=Deprecated functions! It’s never a problem with the programmers that code in php, but php.org itself.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.