[resolved] Code changes needed to make cforms II work over https (5 posts)

  1. Christiaan
    Posted 6 years ago #

    Does anyone know which files/code need to be altered in cforms II so that it doesn't make people's browsers throw up the "nonsecure and secure items found" error, when using https.

  2. tmuka
    Posted 6 years ago #

    You probably figured it out by now, but cforms seems to get the site url from the general settings page when it is activated. If you just changed your site to use SSL, de-activate and re-activate the cforms plugin. It worked for me.

  3. damania
    Posted 6 years ago #

    Hi tmuka, I tried your suggestion. I changed the Blog address (URL) to https://3packet.com and reactivated the cforms plugin. THe form still hangs on https:// unfortunately. I tried it with changing the Blog address (URL) back to https://3packet.com but not reactivating cforms. That's its current state.

  4. damania
    Posted 6 years ago #

    More info:

    I noticed I get this error in ie8 (the yellow error triangle in the left side of the status bar):
    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; WOW64; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Timestamp: Sun, 11 Oct 2009 05:04:26 UTC

    Message: Permission denied
    Line: 121
    Char: 1
    Code: 0
    URI: https://3packet.com/contact-us/

  5. damania
    Posted 6 years ago #

    I figured it out.

    First, I went into wordpress general settings and changed the wordpress and blog address to https://(site). Then I went to cforms and went to the exact form and updated it (update button on top right side). Then I went back to general settings and rechanged it back to http://.

    Then I changed the cforms_root line as referenced here in entry 4:

    Then the captcha and submit button wouldn't work, so I went into plugin editor -> cforms -> js/cforms.js and changed the sajax_uri variable to either "https://(fullpath)" or '/wordpress/wp-content/plugins/cforms/lib_ajax.php';

    The path may or may not include /wordpress for you depending on your path.

    My website is at http://3packet.com

    Good luck all!

Topic Closed

This topic has been closed to new replies.

About this Topic