WP SyntaxHighlighter
Code button not visible/usable unless "Unfiltered HTML" privelage is granted (2 posts)

  1. cjmusante
    Posted 2 years ago #

    I'm using your plug-in in conjunction with another plug-in called Advanced Access Manager. Both plug-ins are great, and both deliver a great deal of capabilities that I need on my site.
    What I have found is that, the "Code" button which you add to the editor window is not visible to authors unless I use the Advanced Access Manager to grant them the access privilege to "Unfiltered HTML" as defined in the Advanced Access Manager (http://wordpress.org/extend/plugins/advanced-access-manager/ ) plugin.
    I've discovered at least one other plug-in that also requires that I grant access to a very special privilege, in order to get the plug-in to work.
    To determine that the root cause was that this specific capability was needed I first noted that the Manager role had access to the reports, while the Author role does not. I compared the role of author and manager, and one after another, I enabled or disabled each individual capability until I had isolated the culprit.
    Is there anything you can do to declare separate capabilities, such as Use Syntax Highlighter? That would be ideal.
    Any thoughts on this problem?


  2. SarahWallace123
    Posted 2 years ago #

    I have a HTML page, and the code is not showing up. The only thing showing up is the link code.

    How do I recover this code? Please help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP SyntaxHighlighter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.