Support » Plugin: Page Builder Gutenberg Blocks – CoBlocks » CoBlocks form not working

  • Resolved xavric

    (@xavric)


    Hi there,

    I’m using CoBlocks to include an Email form in my website but it doesn’t send them out and I get no confirmation notice of any kind. I have tested my wordpress configuration (with Check Email plugin) and it works fine, so the issue probably resides with CoBlocks.

    Strange enough it worked ok a few months ago.

    Anything I can do to solve this ?

    Thanks,
    @xavric

    PS : I have already tried by disabling all my plugins and I have the last versions of WP, CoBlocks and theme.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Anthony Ledesma

    (@paranoia1906)

    Hi @xavric,

    Sorry to hear that you are experiencing some issues with email delivery. There is not a whole lot that we can do to help troubleshoot but I have a few ideas. I’ve seen situations where the Webhost does not like the subject we are sending with the form and will block submission emails from being sent. There are also cases where the address that is set as the recipient may have a block of some sort placed on the email relay server where your emails are being sent from. These two scenarios can result in the behavior that you report. I am curious about what you have set for your recipient email but more specifically what is set for your subject line in your contact forms.

    The CoBlocks form uses basic PHP mail functionality which is generally pre-configured by your WebHost. I advise you to check with your WebHost and see if they can identify the issue within email logs. Hope this is helpful. Let us know if you find the cause.

    Best regards,

    Anthony

    Thread Starter xavric

    (@xavric)

    Hi Anthony,

    Ok I will contact my webhost.

    Thanks,
    xavric

    Hi @paranoia1906!

    Can you run a test to make sure it’s working on any test sites you may have?

    With a colleague of mine at Automattic, I’ve ran a few tests across multiple infrastructures (WordPress.com, SiteGround, personal server…) with various different configurations. Alongside Jetpack’s Form, Contact Form 7, and WP Forms — all work but the CoBlocks. This was originally reported by a user we were assisting where Jetpack’s Form was working but not the CoBlocks.

    I’m not seeing that the form is making a successful call to wp_mail() and the message doesn’t seem to leave the form. The mail attempt isn’t being captured by any mail logging plugins I have installed, either.

    I’m investigating further before moving to a Github issue.

    • This reply was modified 1 year, 5 months ago by verygoode.
    • This reply was modified 1 year, 5 months ago by verygoode.
    Thread Starter xavric

    (@xavric)

    @verygoode,

    Yes indeed. It looks like the plugin behaves just like you described. However I tested with another plugin (very simple contact form) and got the same issue. I will try with CF7 (which I wanted to avoid so far) to see what comes up.

    Best,
    @xavric

    Thread Starter xavric

    (@xavric)

    Hi again,

    So, I just tested Contact Form 7 with the same webhost, and it works perfectly! Therefore we can assume that there is something wrong with the “form” block of CoBlocks not calling wp_mail().

    If CoBlocks comes with a fix, that would be great.

    Best,
    @xavric

    Thanks for the update @xavric!

    I’ve reported this issue on their Github as I worked with a few more users experiencing the same issue — perfectly fine mail settings with other forms working.

    https://github.com/godaddy-wordpress/coblocks/issues/1466

    CC: @dfeuster @paranoia1906

    Thread Starter xavric

    (@xavric)

    @verygoode

    Great, I’ll keep an eye on your Github ticket.

    Thanks,
    xavric

    @xavric add google reCaptcha keys, it will work.

    Thread Starter xavric

    (@xavric)

    @spwangwp thanks for the tip, it does work much better with reCaptcha indeed.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘CoBlocks form not working’ is closed to new replies.