Support » Plugin: Co-Authors Plus » coauthors_posts_links not linking to author page

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Daniel Bachhuber

    (@danielbachhuber)

    Hand Built

    A few questions:

    • Can you share the exact code you’re using?
    • What other plugins are you using, and does it happen with those plugins off?
    • What are your permalinks set to?

    The code I am using is:

    if(function_exists('coauthors_posts_links')){
    	coauthors_posts_links();
    }
    else {
    	the_author_posts_link();
    }

    None of the other plugins I am running seem to effect this behaviour. When I disable Co-Authors Plus, the problem is fixed.

    My permalinks are set to default http://www.example.com/?p=123

    I’m having what appears to be a related problem; my author links using get_author_posts_url() point to my blog’s home page with Co-Authors Plus 3.0.1 (WordPress 3.4.2) enabled rather than the author’s page. When I disable Co-Authors Plus, the link points to the author’s page correctly.

    A sample of the code in question is:

    <a class="authorname" href="<?php echo get_author_posts_url(1); ?>"><?php echo get_the_author_meta('display_name', 1); ?></a>

    This code has worked with pre-3.0 versions of Co-Authors Plus; I can’t swear on which upgrade it stopped working since I only noticed this morning.

    Permalinks are set to default as with ad4mlaz.

    Plugin Author Daniel Bachhuber

    (@danielbachhuber)

    Hand Built

    Sorry about that. I’ve confirmed the issue and have pushed a fix in 3.0.2, released just now.

    @lord Bob: You’ll want to use the coauthors_posts_links() as indicated above.

    Thanks Daniel.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘coauthors_posts_links not linking to author page’ is closed to new replies.