Co-Authors Plus: Autocomplete not working after upgrading plugin (9 posts)

  1. devaka
    Posted 3 years ago #

    Today I've updated plugin Co-Authors Plus in my WordPress and now can't add new authors to the post because of auto-complete problem. Has anybody had this problem and how to resolve it?

    Thanks in advance!

  2. devaka
    Posted 3 years ago #

    after detailed testing can say what it search author by nickname or email, but not search by utf8 author name :( like "Сергей"

  3. devaka
    Posted 3 years ago #

    Here is some screenshots:

    search working by english words

    but not working for russian words... in previous of plugin version I had no this problem

  4. devaka
    Posted 3 years ago #

    solved problem by hacking wordpress:
    file: wp-includes/user.php
    line: 487
    added string: , 'display_name'

    so it now:
    $search_columns = array('user_login', 'user_nicename', 'display_name');

    it has solved my problem with autocomplete but now dont know if it influence on front-end website speed? )

  5. Nooo, never do that, ever. Modifying the core is always a bad thing to do.

    So can you explain what you are trying to accomplish again? I've re-read this and I'm still unclear.

  6. devaka
    Posted 3 years ago #

    Jan Dembowski, thanks for reply!

    Problem seems in get_users function what cant search for display_name.
    But previous version of co-authors plugin worked well...

    In other words, I try to select author when creating new post and can't select by display_name. I've attached screenshots few posts above.

  7. Sadly, it'll be about 12 hours before I can look at that plugin. It's just not one that I've ever looked at.

    If you mean this plugin http://wordpress.org/extend/plugins/co-authors-plus/ then you may be in luck. The author is very active here in the forums and I've added a tag for that plugin.

    Perhaps you'll get a reply that can help sort it out.

  8. Daniel Bachhuber
    Hand Built
    Posted 3 years ago #

    Sorry about that. I forgot to hook a filter back up in the most recent release. I'll have an update out for it today.

  9. devaka
    Posted 3 years ago #

    Daniel, Jan, thanks a lot!

Topic Closed

This topic has been closed to new replies.

About this Topic