Support » Plugin: Windows Azure Storage for WordPress » CNAME not saving with HTTPS

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Morgan Estes

    (@morganestes)

    Hey @andym3kt, the CNAME is saved in the options table, but gets rewritten to http:// on the fly to prevent the conflicts with the Storage SSL support. In your case when you have a Azure CDN with SSL support, you can bypass the URL rewrite with a filter to ensure your CNAME gets used.

    Include add_filter( 'windows_azure_storage_allow_cname_https', '__return_true' ); in your theme’s functions.php file or in a plugin to enable your SSL CNAME CDN (that’s a whole lotta letters!).

    this still messes up the srcset values. I would suggest to not tinker with user provided urls. That is really annoying.

    Make a warning on the settings page and leave the inputs as is.

    nevermind, it works with the add_filter(…)

    please make it a regular chewckbox or warning only anyway

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘CNAME not saving with HTTPS’ is closed to new replies.