WordPress.org

Forums

[resolved] Clueless (that's me). 500 Error help please. Godaddy response.. (21 posts)

  1. droolinc
    Member
    Posted 5 years ago #

    Trying to simply access my WP 2.7 install from to my free shared Godaddy Windows IIS7 server. Getting the 500 error message that I see everyone gets. I've also tried this on Media Temple. I've been trying to do this for two weeks and am about to toss WP. I'm really frustrated and worst of all I know this is simple.

    I have installed, renamed, deleted a .htaccess file that I created with Mac Notebook about ten times. It simply reads: php_memory_limit: php_value memory_limit 42M

    I added it once I got the 500 error as I had been though this with MT. ( Their issue was that you have to be on a dedicated or Grid and I have a Shared account that runs on 4 not 5. - took them four days to figure that out. )

    I have no idea what some of Godaddy's message means. "upload .htaccess files in ASCII mode" How? I use Fetch to FTP my files. "Set the permissions to 644?" No idea what or how.

    Could someone who is a pro look at the message below and help me finally install, activate WP? PLEASE!

    ------------- Godaddy's message:

    "Thank you for contacting Online Support. I have provided additional information on the error you are receiving below:

    Error Message:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/1.3.33 Server at mydomain.com Port 80

    Cause:

    This error can be caused by a variety of issues but is most likely caused by a corrupt .htaccess file. Check to see if there is an .htaccess file in the directory where the error is being generated or any directory above in the tree. If so, temporarily rename the .htaccess file and refresh the page. If the error does not reappear, the .htaccess file is the issue. Repair the file or leave it disabled.

    Most of the time .htaccess issues are caused by trying to overwrite PHP settings, being uploaded in binary format or permissions issues.

    Resolution:

    Be sure to upload .htaccess files in ASCII mode

    Set the permissions to 644, which makes it useable by the server, but prevents it from being read from a browser.

    If you are trying to make changes to PHP settings, be sure to make said changes to the php.ini file.

    For more information see How do I view my CGI error logs.

    Thank you for contacting Online Support. I have provided additional information on the error you are receiving below:

    Error Message:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/1.3.33 Server at mydomain.com Port 80

    Cause:

    This error can be caused by a variety of issues but is most likely caused by a corrupt .htaccess file. Check to see if there is an .htaccess file in the directory where the error is being generated or any directory above in the tree. If so, temporarily rename the .htaccess file and refresh the page. If the error does not reappear, the .htaccess file is the issue. Repair the file or leave it disabled.

    Most of the time .htaccess issues are caused by trying to overwrite PHP settings, being uploaded in binary format or permissions issues.

    Resolution:

    Be sure to upload .htaccess files in ASCII mode

    Set the permissions to 644, which makes it useable by the server, but prevents it from being read from a browser.

    If you are trying to make changes to PHP settings, be sure to make said changes to the php.ini file.

    For more information see How do I view my CGI error logs.

    "Thank you for contacting Online Support. I have provided additional information on the error you are receiving below:

    Error Message:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/1.3.33 Server at mydomain.com Port 80

    Cause:

    This error can be caused by a variety of issues but is most likely caused by a corrupt .htaccess file. Check to see if there is an .htaccess file in the directory where the error is being generated or any directory above in the tree. If so, temporarily rename the .htaccess file and refresh the page. If the error does not reappear, the .htaccess file is the issue. Repair the file or leave it disabled.

    Most of the time .htaccess issues are caused by trying to overwrite PHP settings, being uploaded in binary format or permissions issues.

    Resolution:

    Be sure to upload .htaccess files in ASCII mode

    Set the permissions to 644, which makes it useable by the server, but prevents it from being read from a browser.

    If you are trying to make changes to PHP settings, be sure to make said changes to the php.ini file.

    For more information see How do I view my CGI error logs."

  2. kmessinger
    Forum Moderator
    Posted 5 years ago #

    I have installed, renamed, deleted a .htaccess file

    If you deleted this on the server and are still getting a 500 error then it is not the .htaccess file.

    Delete the htaccess file. Confirm that you still get a 500 error.

    What is your url?

  3. droolinc
    Member
    Posted 5 years ago #

    One change I figured out how to upload in ASCII mode. I'll give it a go, but I'm quite sure this will change nothing.

  4. droolinc
    Member
    Posted 5 years ago #

  5. droolinc
    Member
    Posted 5 years ago #

    Deleted the htaccess file and still get a 500 error.
    I'm going to delete WP and upload the entire thing again under ASCII. Again I'm sure this will change nothing...

  6. droolinc
    Member
    Posted 5 years ago #

    After uploading all the WP files again, I get this when attempting the install script:

    "
    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.
    "

    There is no htaccess file in my directory anymore either.
    Come on WP, a little f'in help already...

  7. droolinc
    Member
    Posted 5 years ago #

    OMG!!!! I fixed it! It's up after two bloody weeks!!!!
    Ok, this is what I did in-case there are other's that have this issue with Godaddy.

    Issue is with your wp-config.php set up.
    Godaddy must require you to use your unique MYSQL Database "host name." So not "local host" or the one provided by WP here in the "possible DB_HOST values":

    DB_HOST
    The hostname you determined in Step 2 (usually localhost, but not always; see some possible DB_HOST values).

    You can find it under your "MySQL Database Information" on Godaddy's Hosting Control Center = dashboard. I entered that exact long name, which is specific to my url and blog name, in the wp-config.php and bang the WP install scripted worked!!!

    I'm thrilled.
    P.S. "kmessinger" was correct this had nothing to do with a htaccess file and no Godaddy did not help me in the least in getting this resolved.

  8. Samuel B
    moderator
    Posted 5 years ago #

    if godaddy was really going to help you, they would steer you away from their crappy windows servers and towards their reliable linux servers

  9. Mark / t31os
    Moderator
    Posted 5 years ago #

    Given a choice, i'd always choose a Linux server myself...

    Glad to hear you got it sorted droolinc, and nice one for posting how you resolved your problem to... ;)

  10. Samuel B
    moderator
    Posted 5 years ago #

    Given a choice, i'd always choose a Linux server myself...

    same here...it's not that I have anything against windows servers - they work well on some hosts
    but godaddy just sticks their fingers in their ears and shout, "lalalalalalala"

  11. droolinc
    Member
    Posted 5 years ago #

    Like I said, they didn't help. I asked for a Linux upgrade and they only would give me the IIS7 as it runs php. This is my forth site (first WP though) and Media Temple was not helping either. They are attempting to push everyone to dedicated or grid and from what I've read about their Grid Servers I'm happy to give a free Windows one a shot first.

    @t31os_ Thank you, I really appreciate it!

  12. Samuel B
    moderator
    Posted 5 years ago #

    Like I said, they didn't help. I asked for a Linux upgrade and they only would give me the IIS7 as it runs php

    you don't need their permission
    just log in to your host panel and on the right hand side is "switch operating systems"
    just do that and it's free

  13. droolinc
    Member
    Posted 5 years ago #

    @samboll
    Thank you, I'm going to do so now!
    By the way, they told me I could switch, but it would cost $$.

  14. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    @droolinc
    Sorry for the confusion. It's free to switch operating systems. Here's how to switch: http://help.godaddy.com/article/1285

  15. droolinc
    Member
    Posted 5 years ago #

    Naw, I tried to do it. It cost money to "upgrade" you cannot just switch up to Linux from a free account as part of the domain registrar.

    Like everyone, most everyone, most Mac everyone's, I cannot upload photos to my site either. I've gone through a mass amount of threads, like everyone, done everything and nothing has worked.

    I'm really shocked at how buggie WP is. It's too bad I would have like to have used the software, but I'll probably just build a site now in DW. Seems a lot less time consuming.

    Thanks for the help and good luck in the future.

  16. droolinc
    Member
    Posted 5 years ago #

    It's a permission error. Godaddy doesn't see the upload. You can change it in the File Manager under permissions for uploads. Only issue now is that I've changed it and saw it upload, I no longer have a site. My entire site is blank, even after changing the permissions back.

    This is ridiculous and yes, I'm going to post this again on the upload thread.

  17. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    The free ad-supported hosting may have difficulty interacting with some applications. This could be why you're having these issues. I would recommend upgrading to paid hosting.

  18. Chris_K
    Member
    Posted 5 years ago #

    The free ad-supported hosting may have difficulty interacting with some applications.

    A quick search here in the forums would confirm that statement.

  19. droolinc
    Member
    Posted 5 years ago #

    I think a paid account on GoDaddy would be a waste of money seeing as I already have a Media Temple account. They are a proven stand alone host and I've been using them for many years. I would hope in the future that Godaddy would stop wasting consumers time with free accounts if they cannot support a simple interface like WP.

    Your support department was not of help at all and never once said there might be "The free ad-supported hosting may have difficulty interacting with some applications."

    We'll be dumping GD shortly and migrating either to MT or pointing to WP directly. A short cut that seems like a smarter alternative.

  20. johnnbymn
    Blocked
    Posted 5 years ago #

    Thanks a ton. I had exactly the same problem and changing the host name worked great. I called goDaddy and the guy on the other end was the least helpful person I've ever come across, he sounded about 105 years old.

    Anyway, thanks for posting the solution to the problem. Big help!

  21. johnnyguru222
    Member
    Posted 5 years ago #

    @samboll: same here...it's not that I have anything against windows servers - they work well on some hosts
    but godaddy just sticks their fingers in their ears and shout, "lalalalalalala"

    LOL. They just did that to me yesterday.

Topic Closed

This topic has been closed to new replies.

About this Topic