Support » Plugin: Flying Images by WP Speed Matters » CLS seems to be an issue with this plugin

  • Resolved svenv

    (@svenv)


    Hi,

    We’re experiencing CLS for images even when the resolution is set:
    CLS: https://prnt.sc/11iosir
    Resolution: https://prnt.sc/11ip466

    I realize the size set is higher than the display as it’s set to “Full” in Elementor, but without Flying Images this does not cause an issue. It’s responsive so it’s hard to set the resolution that will always work.

    Is there any solution to this except for excluding the image from lazy loading?

    Thanks.

    Regards,
    Sven

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Gijo Varghese

    (@gijo)

    Thread Starter svenv

    (@svenv)

    It isn’t a duplicate as width and height are set as in the solution provided by you in the other topic. But still we have CLS issues.

    I just came across the same issue. <img> is with set width and height, but flying images’ placeholder is set to a different aspect ratio, causing CLS.
    Image link also contains name with correct resolution, and there is no other mention of any different aspect ratio. So I have no idea where from is flying images taking that wrong aspect ratio. And I also can’t force the aspect ratio with css and the image can’t have fixed size.

    autoptimize is great example where it is not happening. But there is missing free optimization of images and also flying images CDN doesn’t work with it 🙁

    Thread Starter svenv

    (@svenv)

    Yes Autoptimize / AI by shortpixel there is no CLS. However their CDN / service we found to be significantly slower than Flying Images.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘CLS seems to be an issue with this plugin’ is closed to new replies.