Support » Plugin: Query Monitor » Cloudflare / WP-Lister conflict

  • Resolved JapeNZ

    (@japenz)


    Hi there,
    I’m trying to use WP-Lister to list products on eBay, it works fine if I do them individually but when I try to do bulk listings I get the Cloudflare 520 Error.

    I had a a look around and found the following:

    520 (Origin Error) in AJAX calls
    Cloudflare Error 520, 522

    Deactivating Query Monitor fixed the issue.

    Is there a work around at all?

    Thanks for your help!

    Kind regards,
    JP

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi JP,

    in my experience, Query Monitor can use quite a lot of memory – especially on sites with many plugins and many SQL queries – and disabling it simply helps because you lower the memory requirements. WP-lister is also quite complex and can use a lot of memory when processing bulk actions, so it’s not a big surprise that both combined might require more memory than allowed.

    I really like Query Monitor and I use it a lot, but I’ve seen it quite a few times where I would only get some HTTP 5xx error code (getting a 520 from Cloudflare is not much different than a 500 directly) and I could “fix” the problem by either disabling Query Monitor, or by doubling the amount of memory allowed for PHP. (even up to 1GB, which of course isn’t recommended on production sites)

    kind regards,
    Matt

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Query Monitor version 3.0 uses quite a lot less memory than previous versions, but it can still cause issues if you have a mixture of a low memory limit and a poorly performing site, for example a high number of database queries or high memory usage.

    There’s not much that can be done about this other than increasing your site’s memory limit.

    Hi @wp-lab and @johnbillion,
    Thanks so much for the feedback guys.
    I assumed it would be due to a hosting / memory limitation, so it’s good to know it’s not a conflict of any kind.

    I’ve only hit the issue when doing bulk updates, which I don’t do too often. Easy fix is currently just to deactivate Query Monitor when I do these.

    By memory limit, would this be allocated memory on the host side, WP memory limit or something else?
    I have the WP memory limit set to 2GB, so I’m guessing it’s not that lol!

    Is this something that can be fixed with htaccess or php.ini files, or is it on the hosting end that would require an upgrade do you think?

    Anyway, thanks again for you help!

    Kind regards,
    JP

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    If you look in the Environment panel of Query Monitor, the actual memory limit is shown under memory_limit in the PHP section. If this isn’t showing 2G then you’ll need to get in touch with your host and ask them about increasing the memory limit, although that’s quite a high limit to ask of most hosts.

    It’s probably easiest for you just to deactivate QM while you perform these sorts of actions, it’s not going to show you anything that’s useful to you anyway unless you’re the maintainer of the WP-Lister plugin 🙂

    That’s right, but if you’d like us to look into this then I highly recommend to do this on a staging site, so we can examine the memory consumption in your specific case, without any chance of breaking your live site.

    You can use the support form on wplab.com to contact us, if you would like us to do so. If your hoster offer a staging site option that would be great, if not then we’d use the services of wpstagecoach.com to create a staging site.

    kind regards,
    Matt

    P.S: @johnbillion: Love the new 3.0 layout! Great what you’ve done there! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Cloudflare / WP-Lister conflict’ is closed to new replies.