Support » Plugin: WP Cloudflare Super Page Cache » cloudflare test cache not working

  • Resolved ops159

    (@ops159)


    In the picture below everything is in the middle. and I’m just using the autooptimize plugin. but it gives a disable boot from others error

    Photo

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @ops159,
    I think you forgot to share the screenshot link that is why I didn’t get your question fully. Can you please provide the screenshot and explain your question a bit?

    Thread Starter ops159

    (@ops159)

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @ops159,
    Please note that the “Test Cache” button uses cURL to get the response headers and check if Cloudflare cache is working or not. Though it is an easy way to test but not the right way as sometimes when Cloudflare sees a request is coming via cURL it simply sends back the request as dynamic.

    But if you use the browser developer tools and go inside the network tab to check the response headers you are getting for your website, that’s where you will see the actual correct data. When I checked your website via a browser, I can see that Cloudflare cache is working perfectly and it is caching your website as indented. Check the screenshots below:
    https://i.imgur.com/Rv1TPP7.png
    https://i.imgur.com/Fp1ayII.png

    Hope this helps. ๐Ÿ™‚

    Thread Starter ops159

    (@ops159)

    Thank you for your nice answer. these pictures do not open. Did you say that it works now even though it gives such warning? Also, if there is a problem, I would like to contact you via e-mail can you fix it if necessary. I just did not understand this job. because the picture I sent tells me that things are not going well.

    Thread Starter ops159

    (@ops159)

    and the pictures you send are not opening at all

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @ops159 ,
    please follow the directions given in the dialog box. Check with your browser for Cloudflare’s response as the cache test sometimes fails.

    If you want, share the link to your website and we will check it for you.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @ops159,

    these pictures do not open

    Can you see if you can see these images:
    https://pasteboard.co/JtAKIb3.png
    https://pasteboard.co/JtAKWeV.png

    Did you say that it works now even though it gives such a warning?

    I already explained in the above reply why sometimes you may see that warning and what is the best way to check your response headers for your website using the browser dev tools.

    Also, if there is a problem, I would like to contact you via e-mail can you fix it if necessary

    Unfortunately no. This is a free plugin and we do not provide personalized email support for free. But the email id is mentioned in the plugin settings page in order for our users to send logs and other sensitive information which cannot be posted in a public forum.

    I just did not understand this job. because the picture I sent tells me that things are not going well.

    It is a bit more technical than just things are not going well. As far as I can see and as I explained above in my previous reply, checking the response for your website when using the browser is returning the correct result. But as explained above the “Test Cache” button uses cURL (https://en.wikipedia.org/wiki/CURL) to fetch the response header and to see if the response header has appropriate cache headers or not. But as explained above, sometimes Copuldflare does not provide a cached copy of a website when the request is coming via cURL that is why you need to check your response headers by actually opening the website in a browser.

    Hope this helps. ๐Ÿ™‚

    Thread Starter ops159

    (@ops159)

    and please tell me exactly which file and what to attach. Or would it be a problem if it stays like this? does it work properly? really thank you so much. I can’t solve the situation like this.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @ops159,
    As stated above, The Cloudflare caching is working properly on your website as it is caching your requests. Please check the screenshots shown above. Also if this doesn’t satisfy your curiosity, do check the response headers by opening your site on an actual browser (possible in incognito mode and not logged in situation).

    1. Open incognito window in chrome
    2. Right-click and select “Inspect Element”
    3. Click on the “Network” Tab
    4. Enter your website URL and load the site
    5. Click on the first request with response code 200 in the network tab
    6. Check the “Response Headers” and look for cf-cache-status value. If the value is HIT that means the page is being served from Cloudflare cache.

    Hope this helps. ๐Ÿ™‚

    Thread Starter ops159

    (@ops159)

    ok if you checked it is enough. thank you . I realized that the test cache error is trivial

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @ops159,
    Just to be clear if you click on the “Test Cache” button you still see the same message you have shown before?

    Thread Starter ops159

    (@ops159)

    yes error :
    Page caching is working for static page but seems not working for dynamic pages.

    Error on dynamic page (https://siteurl.com): Invalid Cache-Control response header. If you are using Litespeed Server, please disable the option Overwrite the cache-control header for WordPress’s pages using web server rules, purge the cache and retry.

    Please check if the page caching is working by yourself by surfing the website in incognito mode ’cause sometimes Cloudflare bypass the cache for cURL requests. Reload a page two or three times. If you see the response header cf-cache-status: HIT, the page caching is working well.

    I’m autooptimize just using

    • This reply was modified 1 year, 2 months ago by ops159.
    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @ops159,
    Well this is wired as CF cache is working perfectly on your website when you check it via the browser as mentioned in the notice:

    Please check if the page caching is working by yourself by surfing the website in incognito mode โ€™cause sometimes Cloudflare bypass the cache for cURL requests. Reload a page two or three times. If you see the response header cf-cache-status: HIT, the page caching is working well.

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @ops159 ,
    the page caching is working properly on your website:

    https://ibb.co/nPdr31Q

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    I’m closing this thread. If you have other issues, open a new one ๐Ÿ™‚

    Bye!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘cloudflare test cache not working’ is closed to new replies.