• Resolved HungryJos

    (@hungryjos)


    After updating to the latest version, I can’t see the cloudflare options (login + API) in the siteground optimizer.
    Cleared the cache and cookies, both on siteground and in cloudflare.
    It doesn’t show up anymore.
    Has anything changed regarding to Cloudflare settings?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Simeon Boev

    (@k3llanved)

    Hello,

    We have included improvements to the Cloudflare integration via our plugin. It will automatically detect if you use Cloudflare via our end(if the service is active in SiteTools). Of course, you could adjust the configuration of the Full Page Caching by enabling/disabling it, as there you will see the option to change login/API settings.

    Best Regards,
    Simeon Boev

    Thread Starter HungryJos

    (@hungryjos)

    I don’t know what you mean by ‘adjusting the configuration of the Full Page Caching’: I don’t see that option in the optimizer setting and previously I had the settings for cloudflare at the bottom of the caching settings. Not anymore:
    Screenshot caching settings

    I don’t have Cloudflare settings from Sitetools as we manage our domains directly in Cloudflare.

    I already contacted support for the same issue in the previous version(s) as Cloudflare would sometimes not show, but now I don’t see any settings at all, even after clearing cache and cookies multiple times.

    Plugin Support Simeon Boev

    (@k3llanved)

    When you click to enable the Full Page Cache feature in our plugin you will be asked to input the email address(account) and API. If the feature is already enabled you would have to disable it first and then enable it again if the account/API has to be updated.

    Best Regards,
    Simeon Boev

    Thread Starter HungryJos

    (@hungryjos)

    As said: I don’t see such feature in the plugin, as you can see in the screenshot I attached in previous message.
    The only reference to full page caching is in the Dynamic caching option. As you said I deactivated it and reactivated it, but there’s is no field appearing to set the Cloudflare email and API.
    Then I went on to deactivate every single feature and clear browser cache and nothing changed.
    There might be something stuck in Cache somewhere, but I can’t say this is an intuitive way of setting this up. As we have multiple similar sites with Siteground, I can’t be expected to go through all this fiddling to be able to set this up in every single site like this, by going through trial and error.

    Plugin Support Simeon Boev

    (@k3llanved)

    Thanks for the update.

    Excuse me for the inconvenience as I misunderstood the issue from the start.

    I took the time to review it further and I activated Cloudflare via their end directly. I wanted to test with different setups in order to ensure that I do not miss anything and indeed the feature in question is no longer present. It is not cache, unfortunately, the tool to manage the Full Page caching is no longer available if the domain is directly pointed to Cloudflare.

    Best Regards,
    Simeon Boev

    Thread Starter HungryJos

    (@hungryjos)

    OK, and is it worth adding the Cloudflare full page caching plugin in addition to the siteground plugin? > WP Cloudflare Super Page Cache (https://wordpress.org/plugins/wp-cloudflare-page-cache/)

    Plugin Support Simeon Boev

    (@k3llanved)

    I think this is more of a personal choice as you already utilize different layers of caching already. Of course, make sure to test and check if another plugin will be beneficial at all. In general, I recommend avoiding additional plugins if possible as bloating the application is never a good idea.

    Best Regards,
    Simeon Boev

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cloudflare options no longer visible’ is closed to new replies.