WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Cloudflare extension error Resolving host timed out: www.cloudflare.com. (7 posts)

  1. guiman87
    Member
    Posted 10 months ago #

    Hello everyone,
    Unable to communicate with CloudFlare API: Setting: zone_settings Resolving host timed out: http://www.cloudflare.com.

    I´m having this error while activating the cloudflare extension for w3 total cache, I´m using justhost.com as a hosting proider, my API KEy and Email are ok.

    Unable to communicate with CloudFlare API: Setting: zone_settings Resolving host timed out: http://www.cloudflare.com.

    Thanks!

    https://wordpress.org/plugins/w3-total-cache/

  2. alexluchini
    Member
    Posted 10 months ago #

    I am having this exact same issue. My email and api have also been checked and are ok.

    I am using w3 total cache with cloudflare (free), bluehost hosting and this is the error I get: Unable to communicate with CloudFlare API: Setting: zone_settings Resolving host timed out: http://www.cloudflare.com.

  3. Watch Teller
    Member
    Posted 10 months ago #

    +1 here. WP3.8.3, W3TC0.9.3, bluehost.com, PHP5.4,

    Previously, without key-in CloudFlare API in W3TC, the speed & security remain function.

    Recently, auto update to WP3.8.X, the CloudFlare start not function well.

    If you installed WP-Control (cron job management), you will detected (need refresh to check) cron job cannot connect (host timeout & ansyc zone_setting) to CloudFlare network. (CloudFlare ticket submitted).

    As above, I tried activate API in W3TC0.9.3 (conservative to upgrade to all major version upgrade). The problem remain unchanged.

    Please kindly check your cron job event (schedule post, email schedule, minify clean up, page cache create & etc & others plugin cron job event).

    Please note that I am also testing apply real cron job pratice in host server currently. (Normally, WP core cron job x000 miniseconds timeout issue)

    Any solution will update here to share.

  4. alexluchini
    Member
    Posted 10 months ago #

    I am not using WP-Control or have any cron jobs active. Also, changing my minify settings doesn't help the issue. I have tried disabling minify, using manual and auto and the error remains the same.

  5. Watch Teller
    Member
    Posted 10 months ago #

    Hi,

    If you have activated page cache & orther, definitely have interval time (cron job) to "clean you Garbage Collection" & "create page cache prime pre-load" & "clean your old CSS & JS minified files". Even system check new version update also a cron job (interval time).

    We need channel (connect) page cache, CSS & JS minified file via CloudFlare.

    Thanks.

  6. Watch Teller
    Member
    Posted 10 months ago #

    Dear All,

    It may be new CloudFlare API issue, please kindly refer my comment in other thread.

    Hope may help you.

  7. Watch Teller
    Member
    Posted 10 months ago #

    Sorry typo error.

    new CloudFlare IPs (IPv4 and IPv6) issue. Refer to my above mentioned link to obtain a "new CloudFlare IPs list".

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.