WordPress.org

Support

[Resolved] Cloudflare

  • Does this work when both nodes are behind CloudFlare’s reverse proxy?

    When I tried to connect my first site with MainWP I got an immediate 523 error.

    All my sites are behind CloudFlare’s reverse proxy, including the main node, and so when I looked up CloudFlare on their site I found a workaround which said, basically, disable CloudFlare’s protection.

    Now, call me old-fashioned if you like, but that doesn’t rate as much of a workaround in my book. Not even a kludge!

    I have years of experience with multiple servers working with CloudFlare, so its a ‘big ask’ to get me to switch off their security, which has saved several sites of mine on more than one occasion, and trust MainWP’s which, as far as I am concerned, is a big unknown quantity.

    So, how about a REAL solution from iControlWP? One like ~ if you just whitelist these IPs and do this or that, everything works fine and the error 523 goes away?

    But not switch off Cloudflare’s security. That’s a non-starter, at least for me it is.

    https://wordpress.org/plugins/worpit-admin-dashboard-plugin/

Viewing 1 replies (of 1 total)
  • Plugin Author Paul G.

    @paultgoodchild

    Hi Terence,

    From the outset we’ve built the system to run with cloudflare as all of our sites are also on CloudFlare.

    We have talked with CloudFlare itself about globally white-listing our IP addresses, but this is something they are reluctant to do in general.

    You can add white lists to CloudFlare itself per-account, so if you do face issues, you can try that.

    We have customers on cloudflare and they don’t have issues, and we also have a cloudflare integration so you can manage certain cloudflare settings directly from within iControlWP itself:
    http://www.icontrolwp.com/2014/02/integrate-cloudflare-icontrolwp/

    Hope that helps!
    Paul.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Cloudflare’ is closed to new replies.
Skip to toolbar