Support » Plugins and Hacks » BuddyPress Group Tags » Cloud Tag URL's not working

Viewing 15 replies - 1 through 15 (of 25 total)
  • Scott

    (@scottwermter)


    I am on the right track. It is an issue with non-buddypress themes and ajax links. With buddypress 1.7 we are not suppose to need a buddypress enabled theme as it is suppose to just work. So there is something in the plugin I think that will need to be changed to make it work with a non buddypress custom theme. I am looking into it but any help would be appreciated.

    I think I’ve solved this issue by adding in a file: bp-group-tags.php (function bp_gtags_setup_globals line 23)
    $bp->gtags = new stdClass;
    It works for me: BGT 2.0.3, BP 1.7.1, WP 3.5.1

    Same issue but your trick didn’t work on my bp 1.7.1 epawel :-\

    Same issue.
    The URL is working with the fix from epawel but the page is empty.

    Is there someone who found out how to make it work?

    I have a similar problem,

    For me the links work when in the tag cloud at the top of the page – but dont work when in the sidebar via the widget.

    URL is exactly the same,

    Hello mate.

    At the moment i got the same problem. The links in the BuddyPress Group Tags is working. But the page shows up as a 404, page not found.

    I tried adding the “$bp->gtags = new stdClass;” in the file but did nothing for me. Perhaps we got some response from the developer.

    I have same Problem? Anyone can help me!

    Same problem here. Someone, anyone? Please help

    Same here. The general cloud works, but the tag lists on the individual group pages lead to error not found page.

    Hi,
    I’m having the same problem with BuddyPress 1.8, BuddyPress Group Tags 2.0.3 and a non BuddyPress theme.

    I was able to get AJAX tag cloud links working, but the “static” page at /groups/tag/tag-name does not work. It seams that nothing catches the /groups/tag/ URL.

    $bp->gtags is not the problem, but it raises a PHP Notice because you can not set properties in runtime. You can fix it replacing

    $bp->gtags->id = 'gtags';
    $bp->gtags->slug = 'tag';

    by

    $bp->options['gtags'] = (object)Array(
    	'id' => 'gtags',
    	'slug' => 'tag'
    );

    and than fixing the bp_core_new_subnav_item call like

    bp_core_new_subnav_item( array( 'name' => ' ', 'slug' => $bp->options['gtags']->slug, 'parent_slug' => BP_GROUPS_SLUG, 'parent_url' => $bp->root_domain .'/'. BP_GROUPS_SLUG . '/', 'screen_function' => 'gtags_display_hook', 'position' => -1 ) );

    I will keep debugging, looking for a fix.

    Hi has someone found a fix for this (and can explain in fix for dummies mode 🙂

    Thanks!

    Hi PauloASilva,

    In what file did you change

    $bp->gtags->id = 'gtags';
    $bp->gtags->slug = 'tag';

    into

    $bp->options['gtags'] = (object)Array(
    	'id' => 'gtags',
    	'slug' => 'tag'
    );

    and where did you add the

    bp_core_new_subnav_item( array( ‘name’ => ‘ ‘, ‘slug’ => $bp->options[‘gtags’]->slug, ‘parent_slug’ => BP_GROUPS_SLUG, ‘parent_url’ => $bp->root_domain .’/’. BP_GROUPS_SLUG . ‘/’, ‘screen_function’ => ‘gtags_display_hook’, ‘position’ => -1 ) );

    Hi hieronymusdesign,
    I did a “DON’T”: I did change a core plugin file.

    First the “bp-group-tags.php”, lines 30 and 31, and than line 43

    Dude, you are my saviour. That did the trick !

    I changed the following (in addition to PauloASilva’s suggestion) and the group’s page shows up properly:

    add any where in “bp-groups-tags.php”:

    function gtags_return_blank() {
        return '';
    }

    modify “gtags_display_hooks()” to look like this:

    function gtags_display_hook() {
      add_filter('bp_current_action', 'gtags_return_blank');
      bp_core_load_template( apply_filters( 'bp_core_template_plugin', 'groups/index' ) );
      remove_filter('bp_current_action', 'gtags_return_blank');
    }

    Post BuddyPress 1.7 (theme compatibility), if the current action is not empty (in this case, it’s set to ‘tag’), then BuddyPress will not treat it as a group directory page.

    I wish this plugin is in github somewhere so that we can at least put the fixes in there.

    Btw, I tested the above with BuddyPress 1.9 Beta 2. It should work with 1.8 as well.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Cloud Tag URL's not working’ is closed to new replies.