Support » Plugin: Popup Maker - Popup for opt-ins, lead gen, & more » Closing pop-up after redirecting to another site via anchor tag

  • Resolved psablik

    (@psablik)


    Hi,

    I have pop-up displaying two images of flags in anchor tags. When the US flag is clicked it redirects to https://emilhandmadeknives.com/en which is English version of website, when the Polish flags is clicked it redirects to https://emilhandmadeknives.com/ which is polish version of website. I’d like to make it so the pop-up closes after the user clicks flag and it redirects to another site. I’ve tried using class="popmake-close pum-close" on the anchor tag, but it only closed the pop-up and it didn’t redirect to site via href. When I added pum-do-default also to class it seems to be working, but after redirecting it pops up again, and after clicking again it finally closes. In this situation, pop-up creates two cookies with the same name in the browser, but with different path: /pl and /en. Could you please help me find a solution to this problem?

    • This topic was modified 1 month, 4 weeks ago by psablik.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Bel

    (@belimperial)

    Hi @psablik

    Thank you for getting in touch, and we are sorry to hear you are having this trouble on your popup.

    I checked the site, and I was able to replicate the issue. I saw that you have properly added a cookie event on the popup. However, it is missing the class popmake-close pum-close on the flags. Could you please add “popmake-close pum-close pum-do-default” to the class attribute and see if this will fix the issue?

    For example: class=”popmake-close pum-close pum-do-default”

    I hope that helps.

    Let us know how it goes on your end or if you have any questions.

    Thread Starter psablik

    (@psablik)

    Hi @belimperial

    Thanks for the reply. I’ve added class=”popmake-close pum-close pum-do-default” to anchor tags as you suggested. Now when I click the flag it redirects me to other site, then it shows popup second time, I have to click it again and then it finally closes. I can see in the browser that it creates two cookies with the same name pum-3742. Can I make it so it doesn’t appear again after clicking the flag and redirecting?

    Plugin Support Maria Togonon

    (@mariatogonon)

    Hello @psablik – apologies for any delays.

    I checked your website and I can confirm the issue that you are referring to. Upon inspecting, I see that the cached files are being loaded. See this: https://share.getcloudapp.com/7KuAwKWz

    May I ask, do you have an Autoptimize caching plugin that is currently active on your website? In line with that, you can try to disable asset caching under your Popup Maker > Settings > Misc and check it again if that helps you solve the problem. You can also check out this demo screencast to make it more clear for you: https://share.getcloudapp.com/bLukzNZy Keep us posted on how it goes.

    If you are still experiencing any issues, and for us to investigate the issue further, this would fall under our premium support, and so please could you open a support ticket at our support portal, here: https://wppopupmaker.com/support/

    In line with that, we will be able to try to replicate the issue from our end.

    We hope for your kind cooperation with this. Thank you.

    Thread Starter psablik

    (@psablik)

    Hi, @mariatogonon,

    Yes, I use Autoptimize plugin. I’ve disabled this option and it didn’t help. I’ve also tried turning off Autoptimize, but it didn’t help either. Still, thank you for the reply.

    Plugin Support Maria Togonon

    (@mariatogonon)

    Hey @psablik – thanks for sending us an update regarding this.

    Like what I’ve mentioned in my previous reply, for us to take a closer look at this further, please could you open a support ticket at our support portal, here: https://wppopupmaker.com/support/

    Looking forward to hearing from you.

    Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.