Support » Plugin: Stream » Close to 180 days of records even after selecting 30 days in settings

  • Resolved htezabwala

    (@htezabwala)


    Hi,

    I am including the screenshots of my plugin settings and stream records.

    There is a sharp contrast between what I want and what actually is happening in storing the records.

    I am seeing more than 180 days of records even though my settings are set to store only 30 days of records.

    Is this behavior normal? How to get rid of the extra records and make sure it doesn’t repeat.

    http://prntscr.com/aclkdc – plugin settings
    http://prntscr.com/aclkzt – stream records

    I’d be really happy if you could suggest a resolution. I’ve seen it happening on a few other sites as well. But this one is a bit bulky so it’s a priority.

    Thanks!!

    https://wordpress.org/plugins/stream/

Viewing 6 replies - 16 through 21 (of 21 total)
  • Luke, sorry to be so slow getting back to you. I deactivated and reactivated Stream on a few sites after getting your message. I just now checked on them, and they still have records going back to January or February when I first started using Stream.

    Are other people having this problem? Could it be a plugin conflict?

    Thanks,
    Donna

    Donna did you reset the database and start from fresh and test it then
    in the Stream Settings /Advanced area
    Reset Stream Database

    Pete, I had not reset the database. I just went in and did that on 40 sites yesterday, and then deactivated and reactivated each site’s Stream plugin. In 30 days I’ll know whether this worked. 😉

    Donna
    Just set one of them to a couple days to test..
    and after 3 or 4 days of no activity listed then you know it is working. then set it back to 30 days if thats what you require

    Hey Luke,

    I tried your suggestion to Donna about deactivating and re-activating the plugin. However, the records are still there.

    More so, they haven’t been purged since the starting of this thread even once. Here’s a screenshot of the current situation – http://prntscr.com/ck4d62

    This is what I see in the console – http://prntscr.com/ck4da7

    P.S. I am on latest version of Stream viz. 3.0.7

    Plugin Author Luke Carbis

    (@lukecarbis)

    @htezabwala Try installing this plugin: https://wordpress.org/extend/plugins/cron-view/

    Use it to see whether or not the cron wp_stream_auto_purge is scheduled, and for when. Let me know how you go.

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘Close to 180 days of records even after selecting 30 days in settings’ is closed to new replies.