Support » Plugin: Yoast Duplicate Post » Cloning content doesn’t appending a -2 to the cloned post

  • Resolved tmounica

    (@tmounica)


    We’ve noticed an issue on our website that when you clone content, WordPress doesn’t appending a -2 to the cloned post. We understand something needs to be appended because two posts cannot have the same URL, it is wildly confusing that it’s the original post that gets this edit.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter tmounica

    (@tmounica)

    Hello There,
    Can any one of you look into the above issue and help me in solving that.

    • This reply was modified 11 months, 2 weeks ago by tmounica.

    Hi @tmounica,
    can you look at the Slug checkbox under SettingsDuplicate Post, tab “What to copy”? If it’s ticked, can you untick it, then save the options and try again?

    Thread Starter tmounica

    (@tmounica)

    Thanks for the reply @enrico Battocchi

    I tried doing that but there is no luck. I have enabled duplicate post option for pages, posts and events. After cloning any of these pages/posts in the permalink section it’s not adding -2. It just showing the cloned post URL. By this 2 posts/pages are having same URL.

    Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    That is definitely strange as it should be a WordPress default that it would add the -2 to the URL. I just tested it out right now and it is adding the -2 as expected.

    If you were to make slight changes to the cloned post (so you can see the differences), and then tried to view both the original and cloned post (at the same URL), are both of them loading the expected content under the same URL?

    Could you check if there’s anything unique in your WordPress setup that could have disabled the adding of the -2 for a duplicate slug or URL?

    Thread Starter tmounica

    (@tmounica)

    Hi @mikes41720 Thanks for the reply,

    What I observed is if I’m cloning any post -2 is adding. But when I’m changing permalink and then clone that post then -2 is not adding.

    Plugin Support Suwash Kunwar

    (@suascat_wp)

    Can you please let us know which in which permalink setting mode are you trying to clone the post? This would help us replicate the issue.

    Thread Starter tmounica

    (@tmounica)

    Thread Starter tmounica

    (@tmounica)

    Hi @suascat_wp
    Is there any update on my issue? Are those screenshots enough to understand my issue?

    • This reply was modified 11 months, 1 week ago by tmounica.
    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @tmounica,

    The settings in the screenshot appear to be correct, so we’ll need to gather more information.

    Can do a test to see if this still happens if you deactivate all plugins except for Duplicate Post and switch to a standard theme like Twenty Nineteen

    We recommend doing this on a staging site or using the Health Check & Troubleshooting plugin.

    We have a step-by-step guide here: How to check for plugin conflicts.

    I have the same issue, with a slight variation, it seems. When I use the clone function, the

      original

    page gets a modified URL, with the -2 on the slug, and the cloned page “steals” the slug of the original page. This of course causes issues, including SEO issues of the kind that Yoast is designed to solve.

    Using the new draft function, things work properly: the new draft gets the -2 marker on the slug.

    The “fix” suggested above, unselecting the “slug” checkbox in settings, is a workaround, it seems to me, not really a fix.

    Please fix.

    • This reply was modified 9 months, 3 weeks ago by LN-CWM.
    Plugin Author Enrico Battocchi

    (@lopo)

    Hi @ln-cwm,
    can you confirm that disabling the “Slug” option fixes the issue?

    This is not a workaround: copying the slug is something that you want to do only on special cases, and it’s disabled by default since version 3.2.2 of Duplicate Post for this reason.
    Disabling the option usually fixes similar issues, but there might be some problems when some other plugin is dealing with slugs (for example using custom fields, copied by default, to store alternative slugs).

    Let us know, and happy holidays!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cloning content doesn’t appending a -2 to the cloned post’ is closed to new replies.