Support » Plugin: NS Cloner - Site Copier » Cloner stuck in a loop

  • Resolved msolution

    (@msolution)


    Hey,
    so i am invoking ns cloner from my plugin as suggested by your docs.

    ns_cloner()->schedule->add

    this code is called via WP_REST_API.

    the main site doesn’t have much traffic so we have a unix cron on wp-cron.php.

    my issue is the logs so created indicate the the cloner is going in a infinite loop in
    CHECKING for running ns_cloner_tables_process – none found
    CHECKING for running ns_cloner_rows_process – none found
    CHECKING for running ns_cloner_files_process – none found

    these lines are repeating over and over again.

    last time this happened, i deleted the said subdomain, and i guess it reset everything, and started with the next one in the queue.

    It got stuck again today, and this with the latest update of Ns cloner, i deleted the said sub-domain, and the script is still looping with the same error messages,

    Going to NS cloner dashboard, I see the popin come forward, with
    (dev console)
    admin-ajax.php?flag=ns_cloner_get_progres gives a 400 error with response ‘0’
    using the cancel button
    admin-ajax.php?flag=ns_cloner_process_exit gives a 400 error with response ‘0’

    i reuploaded the previous version, and then it got ok. and proceeded with the queue.

    If you could contact me via mail, i could drop you the log files, so you can get to a solution.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Never Settle

    (@neversettle)

    Hi @msolution – we can only officially support normal operation for the plugin via the admin UI, so the documentation on running via your own code is meant to be a helpful starting point but it’s ultimately up to the implementer to solve any issues involved with custom integrations. That said, if you want to send your logs to support@neversettle.it we can take a quick look and see if anything jumps out.

    Thread Starter msolution

    (@msolution)

    Hey @neversettle – custom integration is limited to your code as mentioned in the docs. Im just invoking it via REST API.

    the second mention is a bug in your new release, where it is giving me a 400 error in the dev console in firefox. not present in the last version.

    If I could, i would have a feature request of putting a checkbox for people who wish to use unix cron instead of wp-cron. that would be awesome, and simpler!

    Rest things work good and im loving the plugin!

    Keep up the great work!

    Im sending you log files. please look and revert.

    Thanks in advanced.

    Plugin Author Never Settle

    (@neversettle)

    Thanks @msolution! We’ll continue the conversation via our support channel…

    dorike

    (@dorike)

    @msolution @neversettle Hello, were you able to get it resolved? I’m having the same issues too, thanks.

    Thread Starter msolution

    (@msolution)

    no this query was not resolved, nor was the author interested in figuring this out,

    But they do offer paid support for the bugs in their free plugin! 😉

    Best of luck,
    M.

    dorike

    (@dorike)

    @msolution NS Clone is still a nice solution, yet to find something better, but do require some self tinkering. Not sure what boat you are on, but just sharing things I’ve found,

    1 – The plugin installed without a log folder, so that took me some time before getting it to work
    2 – the reason it’s in a never-ending loop is actually quite interesting…
    class-ns-cloner-process-manager.php >> public function finish
    //Update target title since it will have been overwritten by cloned options

    it’s in the if functions below to just update the blog’s title… don’t know why, but I’ve moved it below just before exit_processes(); then it worked.

    3 – Also came across something from the developer, providing some insight to their APIs, or extendibility,
    https://wordpress.org/support/topic/how-to-clone-via-api/

    Hope this helps, good luck!

    • This reply was modified 1 year ago by dorike.
    • This reply was modified 1 year ago by dorike.
    Thread Starter msolution

    (@msolution)

    @dorike oh yes on that we’re on the same page, it is a nice solution, and exactly what i needed at that time, but when i found this bug (and a couple more), we were already way into the project for me to even think about searching for another solution. So i did have to hack into it to make it work.

    another issue being its tied down to wp-cron,
    where a unix cron would do much better on a new site which does not have the kind of traffic this needs to run!

    Thanks for the above, ill look into this.

    Regards,
    M.

    • This reply was modified 1 year ago by msolution.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cloner stuck in a loop’ is closed to new replies.