Support » Plugin: NS Cloner - Site Copier » Cloned site doesn’t use correct Theme and has critical error when I switch

  • Resolved Frank.Prendergast

    (@frankprendergast)


    I haven’t used NS Cloner for a while, it all used to work perfectly.

    But now, on Siteground hosting, when I clone a site the site uses the default theme.

    If I try to switch to the correct theme I get an error saying there’s been a critical error.

    Anyone else experiencing similar, or know how fix?

    Thanks

Viewing 15 replies - 1 through 15 (of 32 total)
  • Plugin Author Never Settle

    (@neversettle)

    Do you have object caching enabled on Siteground? We’ve seen similar error reports where object caching was causing WP to think it had the wrong theme, and flushing the object cache after cloning was all that was needed to make it work normally.

    Thread Starter Frank.Prendergast

    (@frankprendergast)

    So I checked and it was on, I assume you mean what Siteground call memcache. I ran a test and cloned a new site and flushed the cache but no joy.

    However, your tip prodded something in my memory about running into a weird caching issue with Jetpack. I disabled Jetpack and the site appeared as it should WHILE I’m logged in.

    If I open an incognito window and load the site I still see the default theme.

    I ran the above test again and got the same results.

    I am very confused.

    I’m also having a similar issue.

    I’ve deleted all other themes that NS Cloner was reverting to, instead of the desired theme. Also reinstalled the NS Cloner plugin. Now, the cloner just creates a blank page.

    When logged in, it says “template not found.”

    Can you help with this matter?

    Thank you!

    Thread Starter Frank.Prendergast

    (@frankprendergast)

    Hey @brakebeat I’m still trying to resolve this… support are looking into it as well.

    Few questions for you – maybe we can narrow down why we are having this issue by finding what’s common between our sites…

    – What hosting are you on? (I’m on Siteground)
    – What theme are you using? (I’m using Divi)
    – Do you use Jetpack? (I think Jetpack *might* be involved in the problem)

    Thanks,
    Frank

    Hey @frankprendergast same here—reaching out to developer and support.

    Good idea!
    Hosting: WPMUDEV
    Theme: GeneratePress
    Not using Jetpack, so you might be able to rule that out.

    We have tried the caching fix, but that didn’t work.

    When did you start having issues? Since the last WP update was Jan 6, perhaps that’s the problem.

    Our tech expert think it’s either wait it out, bug fix, or find a different cloning plugin. No good solutions.

    p.s. Issues seemed to progress over the past months (e.g. first a theme issue, then non-logged in issue, now a blank template). So it seems like the issues have started to worsen.

    Plugin Author Never Settle

    (@neversettle)

    Have either of you tried using the version of Cloner before you started having issues to rule that out? I have not been able to replicate this issue using our development server.

    @neversettle Yes, we have several successful clones, prior to the issue.

    The previous clones were working perfectly (theme, content, home page, etc.).

    Thank you!

    Thread Starter Frank.Prendergast

    (@frankprendergast)

    Sorry for delay coming back…

    @brakebeat that’s interesting that we have quite different setups and are experiencing the same issue.

    @neversettle yes, was using Cloner successfully and happily for quite a while – but I had not needed to do a clone for a while, and in the meantime Siteground have updated their hosting, WordPress has had many updates, as has my theme and plugins.

    However, the fact that @brakebeat is using different hosting, theme, and plugins would seem to indicate that it is not necessarily related to those things.

    I’m still experiencing the same issue.

    @frankprendergast
    @neversettle

    Today we built a WordPress environment on Oracle cloud to test. It’s still not working. I think it’s a bug. We’ve exhausted all troubleshooting options.

    Thank you.

    Thread Starter Frank.Prendergast

    (@frankprendergast)

    Thanks for the update @brakebeat – it’s unfortunate, we haven’t been able to figure it out either.

    @neversettle support were to look into it, but my host ended up blocking their IP saying there were excessive requests coming from the address – no idea why that would be the case either.

    Have you looked into a viable alternative?

    @frankprendergast @neversettle

    FYI we just tried the new WP update, but the issue continues.

    Solution found, here. Clear object cache on host – in our case, WPMUDEV.

    Thank you, @frankprendergast and @neversettle

    Thread Starter Frank.Prendergast

    (@frankprendergast)

    Thanks @brakebeat that’s interesting. I’ll need to talk to my host. @neversettle mentioned this might be the cause but clearing the object cache on Siteground didn’t do it for me. But given your experience I suspect maybe the issue is with Siteground’s cache or the clearing of it.

    Thank you for coming back with the solution you found!

    Plugin Author Never Settle

    (@neversettle)

    That’s great @brakebeat ! Glad that ended up being the solution as we’ve found the same action usually remedies similar issues.

    Sorry to bump this, but we are using WPMUdev, flushed the object cache, Hummingbird turned off, running WP 5.8.3, but there is still the same problem. It used to work perfect a couple of weeks ago. Am I missing something with the flushing (or some other step). The cloning procedure tells me everything worked fine, but the result is not.

Viewing 15 replies - 1 through 15 (of 32 total)
  • You must be logged in to reply to this topic.