Support » Plugin: Auto Affiliate Links » Cloaking fail

  • Trying to use the cloaked redirect, I have changed it to be “go”, and have saved the permalinks to flush the rules. However the resulting links just link back to the homepage of the site, and do not redirect to the affiliate link as they should. Any idea why this is happening? Thanks.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter tooltrainer

    (@tooltrainer)

    For the moment I’m disabling the cloaking option as I need the links on the site to function. But when you are able to look at this please let me know and I can switch it back on if needed.

    Plugin Author Lucian Apostol

    (@thedark)

    Hello.

    Thank you for reporting this issue. I need more information to be able to figure out what is happening. For example, please tell me what is your permalink structure. You can send a screenshot to contact [at] autoaffiliatelinks [dot] com

    I have tried to replicate your issue on one of our test sites. When I first changed the permalink variable from “goto” to “go”, it didnt worked. Then I changed the variable to “redirect”, when I changed it back to “go” it also worked and I was unable to replicate the issue anymore.

    What I observed is that you need to visit the Settings -> Permalinks page, and the permalink structure will be flushed. There is no need to update anything there.

    Thread Starter tooltrainer

    (@tooltrainer)

    Thanks, I did visit the permalinks page however and nothing changed. I’ll try replicating the steps you outlined here and see what happens, will contact you via email if still stuck. Thanks again.

    Thread Starter tooltrainer

    (@tooltrainer)

    OK “redirect” works fine, “go” does not. Appears to be related to using a very short cloak word.

    Thread Starter tooltrainer

    (@tooltrainer)

    Confirmed, “goto” works fine.

    Plugin Author Lucian Apostol

    (@thedark)

    Hello. Thank you for your valuable input. I will try to see why very short words dont work.

    Amoh Eric

    (@nightwalker101)

    Honestly, I was mad at first why my cloaked links wasn’t working till I read this support article, and I believe the issue lies with not refreshing the permalinks.

    What I also observed is that you need to visit the Settings -> Permalinks page, and the permalink structure will be flushed.

    Though I won’t advise you to update or change your Permalink, for me, it only worked when I used the same setting in the permalink but I click saved again, without changing my old permalink setting.

    Just click save and clear the cache. Then any cloaking word you prefer will work, either GOTO, GO or REDIRECT.

    -Thank You Lucian Apostol (@thedark)

    Plugin Author Lucian Apostol

    (@thedark)

    When the cloaking option was introduced, the rewrite settings were flushed after the plugin settings were saved. Later, WordPress updates changed the way it was working and the calling of the function to flush rewrite rules was discouraged. Later, it started causing problems in some environments and I decided to stop calling it from the plugin, and instead, instruct users to visit the Permalinks settings page, which should work, but it seems that it is not working in all environments. I will change instructions to let people know that they need to save permalinks to make the new cloaking links work.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Cloaking fail’ is closed to new replies.