Support » Plugin: Appointment & Event Booking Calendar Plugin - Webba Booking » client can’t cancel booking

  • Resolved geekayhu


    Hi there,

    you guys have helped me several times, so I hope you can, too, this time.

    I don’t know what I did wrong, but now after making service categories, everything seems to work fine except that the client can’t cancel the appointment, returning the error message “No bookings for payment”

    I tried both leaving the field empty on the price tab in the services settings and setting the payment methods for “on arrival”. In both cases, we get the “no bookings for payment” message.


    note: first, the admin has to approve the booking, then the client receives the confirmation, and could cancel the appointment, but can’t. I left some EN text to make it more understandable for you.

    Any advice would be appreciated!
    Kind regards, Gabe

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author WebbaPlugins


    Hi Gabe,

    Please, copy / paste here the template of the notification sent to a customer.

    Thread Starter geekayhu


    Kedves #customer_name,

    Megerősítettük időpontfoglalásod a következő(k)re:

    #appointment_day • #appointment_time

    Szeretettel várunk szalonunkban.
    Amennyiben biztosan nem tudsz megjelenni, az időpont felszabadításához/törléséhez, kérjük kattints az alábbi linkre:

    #cancel_link (client cancel)

    ________________________ which is roughly in EN:

    Dear #customer_name,

    We have confirmed your appointment for the following: service_name appointment_day • #appointment_time total_amount

    Looking forward to seeing you in our salon.
    If you can’t show up, please click on the following link to free/cancel the appointment: cancel_link (client cancel)


    thanks 🙂

    Plugin Author WebbaPlugins


    Could you please clarify the status of the booking just before the click on the cancellation link?

    Thread Starter geekayhu


    Basically, in the first email (in the video) the admin approved the booking. The client receives the confirmation only after approval. I clicked the link sent to the admin (admin approval), and then in the backend, the status changed to “approved” from “waiting approval” in the Bookings section.

    After that, the client (me :)) received the confirmation, but I couldn’t cancel it.

    The default booking status is: “Awaiting approval” (booking rules)


    I don’t know if it helps at all, but in the email sent to the admin with the admin-cancel-link, as an admin I CAN cancel the booking from the email, however, from the email sent to the client, I can’t.

    And the links in the emails have 2 different numbers. Shouldn’t be the same?

    admin link for the same appointment:

    client link:

    I understand that it should be different, but the code part, too?:
    655617590ee39 (admin) and 655617590ee36 (client)

    Plugin Author WebbaPlugins


    Please, let me know the value of the following option:

    SETTINGS – Booking rules – Advanced settings – Cancellation buffer

    Thread Starter geekayhu


    Oh, got you… 1440 mins, so it means 24hrs.

    So if I client books a slot for “today”, it means they can’t cancel it, unless the buffer time is less than approx. 1hr, right?

    YES, I just checked it. But in this case, the “no bookings for payment” message is misleading (that is why I don’t understand). It should say something like “Bookings can be canceled X mins before…” like we have an option for already paid bookings that cannot be canceled.

    And this type of message exists in the Wording section: “Sorry, you cannot cancel the reservation because you have exceeded the cancellation time allowed for this.” – but I (as a client) don’t get this message, but the “no available payment for booking” message.

    • This reply was modified 3 months, 2 weeks ago by geekayhu.
    Plugin Author WebbaPlugins


    That seems to be a bug – error messages messed up. We will check out and fix in the next release.

    Thread Starter geekayhu


    Thanks so much 🙂

    Kind regards

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.