Support » Plugin: WP OAuth Server (OAuth Authentication) » Client Authorisation no redirect

  • Resolved brianP6

    (@brianp6)


    Hi Justin,

    I finally got around to having time to work with Alexa and after fighting my way through the Amazon jungle I have managed to create the skill I need with the CE version of this plugin – great stuff!!

    However I have two problems that I hope you can assist me with before I buy the PRO version (to support you guys and have a refresh token!) and can then put the skill live (the second is in a separate thread to keep everything neat and tidy).

    When a user authenticates – go to the Alexa skills page, selects the skill, enables … then gets redirected to the authorize endpoint. Login goes well … but then it doesn’t redirect back to Amazon to complete the process, it just carries on with my website. If I disable the skill and re-enable it will properly authenticate – because I’m already logged in to my website.

    Hope you can help,
    Brian.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ha! Now I feel like a dunce.

    Plugin conflicts – Well they’re only doing what they’re configured to do.

    I am running Theme-My-Login and the ‘redirect’ functionality to guide the user to their appropriate page when they login to my website.
    This functionality appears to be over-ruling the Oauth2Server parameter to wp_login_url().

    I’ll investigate this one further Justin to see if I can get what I want.

    But if you can still help me out on the ‘Namespaces’ thread I would really appreciate it – otherwise updates are going to be an absolute nightmare.

    Cheers,
    Brian.

    Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    I have noted namespace issues here and will be working to change them as needed. Keep an eye out for updates.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Client Authorisation no redirect’ is closed to new replies.