Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Clicking "slideshow opens homepage

  • Resolved Lynkos

    (@lynkos)


    I’ve recently started using the free version of NextGen and it seems a great plugin. I’m thinking of upgrading, but before I do so, there’s one strange behaviour I can’t seem to resolve. When I have a thumbnail gallery incorporated in a post or page, clicking on “slideshow” takes me to the homepage instead of opening the slideshow (see: http://lynkos.net/?page_id=3190). Strangely this happens ONLY after the page or post has been published. When still in draft form, using the preview function, it works perfectly. What’s happening and can it be solved? My theme is Blackoot Pro. Thanks, Sarah.

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Author photocrati

    (@photocrati)

    @lynkos – Have you tried changing your WordPress Permalinks to something other than the “Default” such as “Post name” or “Month and name” as better alternatives?

    Otherwise, there could be a plugin conflict going on here or at least it should be ruled out. Have you tried deactivating all of your plugins, clearing your browser cache (and site caches if you are using a caching plugin), then reactivating the NextGEN plugin?

    If this fixes the problem then it was likely one of the deactivated plugins that was causing an issue. Now, retrace your steps activating each plugin and re-checking to see if the problem returns. If it does then that last activated plugin was probably the one. Keep reactivating and in most cases it is also best to keep checking after each plugin, sometimes there may be more than one plugin on a site that will create an issue. If you do find one (or more) plugins causing this problem we would greatly appreciate your feedback on them so the developers may address them as soon as they can.

    Also to note, in rare cases it may be the theme itself that is causing a conflict so while you have just the NextGEN plugin activated you might consider temporarily switching to one of the default WordPress Twenty series themes and see if this corrects the issue as well.

    If the problem still persists after all of this we would still want to know, even more so, as we will still want to sort out the issue and may need additional details.

    Thanks!

    – Cais.

    Thanks so much for the rapid answer and sorry for the delay in replying, I’ve been out of reach of the computer for a few days. I’ll try what you suggest as soon as possible and let you know if it works. Thanks again, Sarah.

    I’ve done some tests and it seems the conflict is with the Polylang plugin. Not sure why this should happen as the plugin is set not to change the URL (http://www.lynkos.net/boxfile/polylang-settings.jpg). Any idea whether I can resolve this conflict or should I look for a workround? Many thanks, Sarah.

    Plugin Author photocrati

    (@photocrati)

    @lynkos – Unfortunately the Polylang plugin appears to remain incompatible with NextGEN Gallery, we recommend WPML for sites that require a Multilingual environment … or plugins that follow its methods.

    Thanks for the follow-up.

    – Cais.

    Thanks for the reply. I’ll look into the possibility of changing to WPML, but as I’ve already based my site on Polylang, it won’t be easy. Thanks again, Sarah.

    Plugin Author photocrati

    (@photocrati)

    @lynkos – You can try going back to the Polylang authors to see if they are working on a solution, or they may be able to provide you a specific work-around for your site?

    – Cais.

    I’ve been having a few computer/internet problems in these last few days, but I will be doing this as soon as they’re resolved. thanks again.

    I have the same problem with Polylang. But I think this is a bug in NGG. I solved it the following way : I’ve edited the file package.module.wordpress_routing.php
    190 $_SERVER['UNENCODED_URL'] = $_SERVER['HTTP_X_ORIGINAL_URL'] = $_SERVER['REQUEST_URI'] = '/'. trailingslashit($new_request_uri);
    replace with
    $_SERVER['UNENCODED_URL'] = $_SERVER['HTTP_X_ORIGINAL_URL'] = $_SERVER['REQUEST_URI'] = trailingslashit($new_request_uri);

    maybe it’s not quite right, but the problem is gone. Polylang and NGG have become friends again )) the Links Pagination and slideshow work properly

    Plugin Author photocrati

    (@photocrati)

    @joys66 – Thanks for the input on this.

    – Cais.

    I’ve been trying to figure out how to implement the editing suggested by Joys66, but I just don’t have the knowledge or experience to figure out. Don’t suppose you could help me out with some instructions for idiots? Many thanks in advance, Sarah.

    Plugin Author photocrati

    (@photocrati)

    @lynkos – The editing suggestion above refers to modifying core plugin files which we do not recommend or support as they are not update safe. Although @joys66 appears to have been successful with their modifications we still recommend WPML as the plugin of choice for Multilingual site requirements.

    – Cais.

    OK, thanks. I’ll take a look at WPML and see if it could work for me, Sarah.

    Plugin Author photocrati

    (@photocrati)

    @lynkos – Thanks!

    – Cais.

    Completely agree that modifying core plugin it the wrong way. But unfortunately to migrate to WPML too late for me ((

    I’ve taken a look at WPML and changing my site concept is just going to be too much work for me and I couldn’t justify the cost either, so I don’t think I have any alternative but to stay with Polylang. BUT I’ve also taken a look at other gallery plugins and Nextgen works by far the best for me. I don’t suppose compatibility might be introduced in an update some time (pretty please)? Sarah.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Clicking "slideshow opens homepage’ is closed to new replies.