Support » How-To and Troubleshooting » Clicking on page 2 redirects to the home page

Clicking on page 2 redirects to the home page

  • Hello,

    I;ve got wordpress with clipper theme… when clicking on paginator (going to page two for example) I get redirected back to the homepage:

    this is the page:


    and on the bottom there are pagination links…

    or directly http://etrgovine.si/page/2/

    What am I to do? have a good knowledge of PHP but I am a complete noob to WP. I don’t even know where to start troubleshooting/debugging..

    please help

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi,

    Actually when I click the ‘Page 2’ myself, I get 404 error. That makes a difference. First I would suggest to update permalink structure.
    Please go to Settings -> Permalinks and click update.


    I figured out that /page/2/ is not even processed as page 2 of the posts…if I turn down the 404_to_home plugin, I get the error that page does not exist…

    at contrary, browsing to the page2 of tags, works as expected




    Did you try to update the permalinks as I advised? Might be also worth to try with default WP permalinks structure.


    Interestingly enough

    http://etrgovine.si/?paged=2 gives me the 404 error….

    http://etrgovine.si/?pageadadd=2 (or any other bogus links) redirects to the home page

    so clearly is something wrong with the interpretation of the paged parameter

    Sorry I was posting in here without hitting refresh so I didn’t see you already replied…

    anyhow, it doesn’t help… as stated in previous post, even if I access directly without permalinks it doesn’t work

    Hi Damir,

    No problem :-). I thought you might be missing my posts.

    Well in that case, I would guess, it’s somehow related to code of the homepage itself, as the pagination itself works fine, not just tags, but have tried on search page and work OK there as well.

    Difficult to investigate now without seeing the code of the theme, but how is the theme itself set? I mean how is the section Settings -> Reading being set? Latest post or specific page? Would you be able to post here the code of index.php, front-page.php (if exists) and home.php (if exists)?




    Forum Moderator

    what is your setting under dashboard – settings – reading – blog pages show at most [ ] posts?

    does the theme set its own ‘posts per page’?

    please contact the developer of your theme for support.

    @alchymyth: it is set to 10, and no, the theme does not override this…

    on the clipper theme website

    it all works ok

    @bouk: it is set to latest posts…


    Having the code of the theme files mentioned above would help. One thing, that could be causing is that slider on the homepage. Is there any option in theme to disable this slider? If so, let’s try that out. It would help us to isolate the problem.


    @bouk: the theme dir has only index.php from the three you mentioned

    ?php	 	  get_header(); ?>
    <div id="content">	
    	<?php	 	  if(file_exists(STYLESHEETPATH . '/featured.php')) include_once(STYLESHEETPATH . '/featured.php'); else include_once(TEMPLATEPATH . '/featured.php'); ?>
        <div class="content-box">
            <div class="box-t">&nbsp;</div>
            <div class="box-c">
                <div class="box-holder">
                    <div class="head">
                        <h2><?php	 	  _e('Najnovejše dodane', 'appthemes'); ?></h2>
    					<div class="counter"><?php	 	  printf(_n('There are currently %s active coupon', 'Trenutno je vpisanih %s trgovin', appthemes_count_posts(APP_POST_TYPE, 'publish'),  'appthemes'), '<span>'. appthemes_count_posts(APP_POST_TYPE, 'publish') . '</span>'); ?></div>
                    </div> <!-- #head -->
                    // show all coupons and setup pagination
                    $paged = (get_query_var('paged')) ? get_query_var('paged') : 1;
                    query_posts(array('post_type' => APP_POST_TYPE, 'ignore_sticky_posts' => 1, 'paged' => $paged));
                    <?php	 	  get_template_part('loop', 'coupon'); ?>
                </div> <!-- #box-holder -->
            </div> <!-- #box-c -->
            <div class="box-b">&nbsp;</div>
        </div> <!-- #content-box -->
    </div><!-- #container -->
    <?php	 	  get_sidebar('home'); ?>
    <?php	 	  get_footer(); ?>

    I did

    <?php get_header(); die(); ?>

    and webt to /page/2

    but stil got page doesn’t exists… so I think the redirect occures before, in some other file

    Hi Damir,

    Apologies for being out of communication. Was bit busy today.

    Just the easiest thing to try – can you take out the line, that includes the php file with slider?

    <?php if(file_exists(STYLESHEETPATH . '/featured.php')) include_once(STYLESHEETPATH . '/featured.php'); else include_once(TEMPLATEPATH . '/featured.php'); ?>


    @bouk: sorry for my late reply … holidays and all that 🙂

    I did remove the featured as you suggested, but nothing changed, page 2 still doesn’t work

    @damirsecki, did you have any luck on this, after all this time 🙂

    I trying the same, change the artificer theme in woo to show products in the index and keep the 4 featured products on top, I managed to shouw products there but pagination won’t work, not even I rewrite the entire theme… 🙂

    Appreciate any help

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Clicking on page 2 redirects to the home page’ is closed to new replies.