Support » Plugin: Multisite Language Switcher » Clicking on flag does not do anything

  • Resolved barrypieters

    (@barrypieters)


    I have two sets of pages in two different languages. A Dutch set on the main domain and an English set on a sub-domain.

    I believe I have made the right connections between the sets of pages and have made the approporiate changes to the header.php and style.css files to make the language flag visible on each page.

    For some reason though, when I click on the flag nothing happens. The flags do not seem to be clickable.

    Thanks for helping. More than happy to provide more info, so let me know what you need to know to help me solve this issue.

    https://wordpress.org/plugins/multisite-language-switcher/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Dennis Ploetner

    (@realloc)

    Please post the URL to the site so I can see what’s going on.

    Cheers,
    Dennis.

    The URL is: http://www.crystallumcoaching.nl.

    I got the MSLS to work, but only by placing it to the very left of the page.

    I think I have learned that if I put the language div to the right, then it is behind another div (<div class=”grid_10 menu_container”>.

    I have no idea if this is possible or makes sense, nor how I would go about stacking divs. Not a front-end developer at all.

    Anyway, thanks for having a look.

    Plugin Author Dennis Ploetner

    (@realloc)

    Seems that you inserted the code before the body-tag which is not correct. Please look into the html-code of your page.

    It sits between the header and the body-tag. I tried putting it in the header. That did not help. Should I put it inside the body tag?

    I just put it in the body (I think). That does nothing either.

    Plugin Author Dennis Ploetner

    (@realloc)

    It works now. Empty your cache (CTRL+F5) … do you have no sidebar in your theme? The widget is much easier to manage.

    I have solved it, by playing around with placing the div in different parts of the body tag. And all this without truly understanding it, but that is ok (for now).

    Thanks for taking time out to have a look.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Clicking on flag does not do anything’ is closed to new replies.