Support » Fixing WordPress » Clicking Edit page gives 403 error

  • Hi,
    I just started receiving this error today, everything was working fine and i didn’t install any specific plugins.

    When in the wordpress dashboard i go to pages and try to edit a page, it gives me a 40 error and says ”
    Forbidden
    Access to this resource on the server is denied!”

    I have already tried by deactivating all plugins but it didn’t work.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Roxanne S.

    (@roxannestoltz)

    Hi @hodstudio ,

    Thanks for reaching out!

    The two most likely causes of the 403 Forbidden Error on WordPress are:

    1. Corrupt .htaccess file
    2. Incorrect file permissions

    As a first step, I would recommend checking that you are set as the administrator by navigating to Dashboard > Users .

    If you are set as the site administrator, the next step would be to locate the .htaccessfile in the root folder of your WordPress site, either via cPanel or FTP, download it to your computer so that you have a backup, and then delete it from your server. Try accessing your website. If 403 forbidden error is resolved, then this means that your .htaccess file was corrupt. To generate a fresh .htaccess file navigate to Dashboard > Settings > Permalinks and click Save changes (even though no changes have been made here).

    Please let me know how this goes.

    Thread Starter hodstudio

    (@hodstudio)

    Hi @roxannestoltz,
    Thank you for your prompt response.
    I just deleted the htaccess file that was in the root directory and there was another one in the public_html directory, so I deleted both.
    After that whenever i try to login to the WordPress Admin i get the following error.
    “There has been a critical error on this website. Please check your site admin email inbox for instructions.”

    I refresh the page a couple of times and then it is accessible but as soon as i click on something i start getting this error again.

    I have placed the backed up htaccess file again in the root directory, but i am still getting this error.

    Roxanne S.

    (@roxannestoltz)

    Hi @hodstudio ,

    Thanks for the update!

    After that whenever i try to login to the WordPress Admin i get the following error.
    “There has been a critical error on this website. Please check your site admin email inbox for instructions.”

    Please confirm if you have followed the instructions in this email?

    The next step would be to check for incorrect file permissions. Please make a backup of your site before this is done in case something goes wrong and you need to restore it to an earlier version.

    Every WordPress file on your site’s server has its own permissions. These settings control who can access and modify its contents. If these files have incorrect permissions, your server will stop you from accessing them.

    If you want to check your file permissions, you can simply contact your hosting provider, and they should be able to take care of it for you.

    If you are comfortable doing this yourself then below is documentation on how it can be done (Navigate to step 3). Please rather contact your host if you are unsure as this could cause further issues to your site if not done correctly:

    https://www.wpbeginner.com/wp-tutorials/how-to-fix-the-403-forbidden-error-in-wordpress/

    Let me know how this goes!

    Thread Starter hodstudio

    (@hodstudio)

    Hi @roxannestoltz ,
    After deleting the htaccess file i put the backup file back in the root directory, i received the error a few more times but then for some strange reason it started working fine.
    So before trying the file permissions instructions i would now wait and see how long does it work correctly.
    Thanks a lot for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.