Support » Plugin: Lana Downloads Manager » Clicking download link directs to blank page

  • Resolved apple2016

    (@apple2016)


    First, let me apologize for not being as web-savvy as I wish to be. Be that as it may, I’ve added the LanaDownloads manager to my website along with SafeSVG to allow svg upload by me. My goal is to allow visitors to download the SVG for free using the LanaDownloads manager. All looks correct, however, when I “click” the shortcode in the post, I’m redirected to a “blank” page. Is this an issue with Lana, with Lana in conjunction with SVG management or operator error? Any aid regarding this issue will be much appreciated. Thank you!

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Lana Codes

    (@lanacodes)

    Please update Lana Downloads Manager for the latest version.

    How to update:
    1. go to “Dashboard > Updates”
    2. click “Check Again” button
    3. Update Lana Downloads Manager plugin to version 1.1.6

    In Download edit page, please fill the File URL in File Manager section (below the text editor).
    So click to the “Upload File” button and select the SVG file.

    To download the file, use the Download URL (not the Post URL).

    Download URL: http://www.diymaven.com/download/4017/
    Post URL: http://www.diymaven.com/lana-download/4017/

    You will find the Download URL in the Downloads list view (Downloads > All Downloads).

    If you have any questions, please feel free to contact me.

    Sincerely,
    Lana Codes

    Thank you. After following your directions, I now am redirected to a page that says “No file path defined.”

    Plugin Author Lana Codes

    (@lanacodes)

    It works for me right now.

    Download URL: http://www.diymaven.com/download/4017/
    … and download Made-for-Each-Other-Valentine.svg file.

    “No file path defined.” – if the File URL field is empty.

    Sincerely,
    Lana Codes

    Clicking the link in your reply works for me as well. However, the hotlink I created in the post (announcing the download), which uses the same URL as the one referenced above, leads to the “No file path defined” comment. I’m guessing I must be doing something wrong in the posting process, which seems pretty straightforward. Any ideas as to what I might be missing?

    Thanks for your patience!

    Plugin Author Lana Codes

    (@lanacodes)

    Can you copy the download URL that is in the post?

    Download URL: http://www.diymaven.com/download/4017/
    – If this url is in the post, it must work.

    – If the url is different, so it is a different download, then the File URL is incorrect (in Download edit page, File Manager section). Or have not saved the download.

    Sincerely,
    Lana Codes

    I believe in trying to solve my problem by starting over, I actually made things worse. After restoring the original download and changing the corresponding URL in the post back to the original URL as well, everything seems to be working now. Thank you for all your help!

    Plugin Author Lana Codes

    (@lanacodes)

    I’m glad to be able to help and find out how to solve the problem.

    I wish you many successes to your website. It looks interesting and useful. 🙂

    Sincerely,
    Lana Codes

    Lana Codes, I have a quick followup. I linked the URL of the download in question to jpg within the body of the post. Although it loads perfectly on my desktop (Mac), mobile devices result in a spinning wheel (no load). However, when one clicks the spinning wheel, the option to download appears. Might this be an issue with the URL being linked to a jpg? Something else entirely?

    Thank you again.

    Plugin Author Lana Codes

    (@lanacodes)

    Can you give me an exact link? Link to the page where the download button is visible.

    Sincerely,
    Lana Codes

    Plugin Author Lana Codes

    (@lanacodes)

    The download link works perfectly. So the Lana Downloads Manager works perfectly. I’ve tested on desktop and mobile too.

    The image is incorrectly loaded due to the “a3-lazy-load” plugin.

    Your website displays the following image:
    https://i1.wp.com/www.diymaven.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif?zoom=1.25&resize=368%2C283

    As you see, because of the “a3-lazy-load” plugin placeholder. This causes the wrong load and the infinite “load” icon.

    So it is possible to deactivate the “a3-lazy-load” plugin.

    Sincerely,
    Lana Codes

    Plugin Author Lana Codes

    (@lanacodes)

    https://hu.wordpress.org/plugins/a3-lazy-load/

    The plugin author can give you more detail about the error.

    Sincerely,
    Lana Codes

    Ah, yes. Lazy Load. I turned off the function for Images in Content, which seems to have fixed the issue.

    THANK YOU again!!

    Plugin Author Lana Codes

    (@lanacodes)

    You’re welcome. 🙂

    Sincerely,
    Lana Codes

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Clicking download link directs to blank page’ is closed to new replies.