WordPress.org

Support

Support » How-To and Troubleshooting » Click on "Leave Reply"-no more sidebar widgets & misalignment

Click on "Leave Reply"-no more sidebar widgets & misalignment

  • Janell2

    @janell2

    Hi,
    I am using the twenty-eleven theme. When the “Leave a Reply” is clicked on the home page North Valley LA all the sidebar widgets disappear as well as the posting, and the content slides over to the right so it only fills half the page. It looks like it loses a lot of the CSS too. What did I do, and more to the point, please tell me how to fix this? I’ve been through the style sheets and can’t see a problem.
    Thanks so much for your help!
    Janell

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi

    @esmi

    Forum Moderator

    Do not edit the Twenty Eleven theme. It is the default WordPress 3.2 theme and having access to an unedited version of the theme is vital when dealing with a range of site issues. Create a child theme for your changes. Once your child theme is active, we should be able to help with the customisation.

    Janell2

    @janell2

    Thanks Esmi…it is going to take me until at least tomorrow to get this back the way it should look after setting up the child theme. I have to figure out the paths and how to get rid of some spacing issues. Looks pretty horrid right now.
    Thanks,
    Janell

    Janell2

    @janell2

    Hi,
    I created the child theme, and still have the same problems, no doubt by carrying over something from the original changed style sheet. The new one is in the directory: twentyeleven-child. The “Leave A Reply” goes far over to the right and is half as wide, the original entry disappears as well as the sidebar widgets.

    Also now, I am getting a hr right below the navigation bar I would love to get rid of, including the space. I need the background to snug right up to the nav bar.

    Also, the other pages that should show up in the navigation bar do not appear as they did before I created the child directory. See http: North Valley La .com / pets.html Once you go to that page, if you click on the logo at the top, you do come back to the WordPress page which is what is intended.

    Thanks you so very much for looking at this for me. I really appreciate you taking the time!
    Cheers,
    Janell

    esmi

    @esmi

    Forum Moderator

    Start by re-uploading a fresh copy of the Twenty Eleven theme.
    http://wordpress.org/extend/themes/twentyeleven

    Janell2

    @janell2

    Hi Esmi,
    I had re-uploaded a fresh copy, but just did it again… I shall obey the diva!
    Thanks,
    Janell

    Janell2

    @janell2

    Fixed the Navigation Bar- except I can’t get the Hover css to work correctly (it is only supposed to change the font color to white, not have a new background color.) What do you do in a child theme to DELETE a style that is on the parent theme’s style.css. I have it commented out and that is not working.

    The other problems remain.
    Thanks!!!

    esmi

    @esmi

    Forum Moderator

    What do you do in a child theme to DELETE a style that is on the parent theme’s style.css.

    You over-write it in the child’s stylesheet. Stylesheets cascade, remember?

    Janell2

    @janell2

    Hi Esmi,
    Yup, rewriting, background: none; did the trick.

    Have you seen why when clicking the “leave a reply” it all moves to the right, the sidebar content disappears as well as the original Post? Also, I’ve been unable to find what is creating the horizontal rule under the navigation bar.
    Thanks so much!
    Janell

    esmi

    @esmi

    Forum Moderator

    Try using Firefox with the Firebug add-on for this kind of work.
    http://getfirebug.com/

    Janell2

    @janell2

    Hi,
    There was a mistake in Twenty-Eleven (least for me it was) on the file: single.php. It was missing
    <?php get_sidebar(); ?>
    before
    <?php get_footer(); ?>

    That was why the widget content did not show up on the sidebar when “Leave a Reply” was clicked.

    I was able to finally figure out why all the content was pushing over to the right side, again when “leave a reply” was activated. On the child theme I added these:
    .singular #content, .left-sidebar.singular #content {
    margin: 0 0;
    }

    .left-sidebar.singular #content {
    margin:0 0 0 0;
    position: relative;
    width: auto;
    }
    .singular .entry-header, .singular .entry-content, .singular footer.entry-meta, .singular #comments-title {
    margin: 0 auto;
    width: auto;
    }

    Hope this helps anyone who was having the same problem. Thanks again, Esmi.
    Cheers,
    Janell

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Click on "Leave Reply"-no more sidebar widgets & misalignment’ is closed to new replies.
Skip to toolbar