Support » Plugin: Cleverwise Daily Quotes » Cleverwise quotes displaying 3 error messages on homepage instead of quote

  • Hi there,

    I’ve been using this plugin on my site for a couple of years now, with no problems until today. I think it makes a great feature.

    this morning, instead of today’s quote, my homepage has this:

    Notice: unserialize(): Error at offset 0 of 1 bytes in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 88

    Notice: Undefined offset: 0 in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 111

    Notice: Trying to get property of non-object in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 111

    Please could you help me resolve it? WordPress, theme (customizr) and plugins all up to date.

    Thank you.

    Jo

    The page I need help with: [log in to see the link]

Viewing 12 replies - 16 through 27 (of 27 total)
  • Plugin Author Jeremy O’Connell

    (@cyberws)

    I understand it can be confusing if you aren’t used to dealing with these kinds of things.

    However part of the confusion is on me. The delete commands had an extra from which is incorrect SQL syntax. My apologizes for that typo. There should be only one where and not before the table name:

    (First where removed)

    delete from wjz8_options where option_name='daily_quotes';

    delete from wjz8_options where option_name='daily_quotes_version';

    Well there is professional assistance available but seeing how this is a hobby site I don’t know if you want paid support.

    Thread Starter johodges

    (@johodges)

    Success! (I think). Now to try to set it all up again – keep your fingers crossed!

    Thank you so much for your patience.

    Thread Starter johodges

    (@johodges)

    Oh dear. I’ve just reactivated the plugin, recreated the quotes section but the tst page shows this:

    Notice: Undefined offset: 0 in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 111

    Notice: Trying to get property of non-object in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 111

    Notice: Undefined index: layout in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 126

    It’s definitely there, because I went in to edit it.

    By the way, I’m puzzled about 2 things. Why, whenever I go into edit it, has the “Check if you don’t have 366 days of content” box become unchecked? And why is it compulsory to check a category, given that I want it on my homepage?

    As a result of my conversation with you, I’ve a support ticket with my hosting provider, as I get these messages when I go into phpMyAdmin.

    A newer version of phpMyAdmin is available and you should consider upgrading. The newest version is 4.8.1, released on 2018-05-25

    Your PHP MySQL library version 5.0.77 differs from your MySQL server version 5.7.16. This may cause unpredictable behavior.

    Are they related, do you think? They say they have upgraded the phpMyAdmin version, but this message hasn’t gone away.

    Plugin Author Jeremy O’Connell

    (@cyberws)

    If you only want the quote to appear on your home page select the no categories option. You may use the shortcode only on your home page.

    The checkbox will only stay checked until you refresh the page because once added there will be 366 quotes.

    Do you know what version of PHP your host is using?

    Thread Starter johodges

    (@johodges)

    4.4.10

    Plugin Author Jeremy O’Connell

    (@cyberws)

    If your host is still using PHP 4.x you need another host.

    Thread Starter johodges

    (@johodges)

    Turns out I was wrong about the php version – I was on 5.6; it’s now been updated to 7.0. It’s phpMyaDmin that’s 4.4.

    After the update, I deactivated. went into phpMyAdmin and reactivated. But I still get:

    Notice: Undefined offset: 0 in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 111

    Notice: Trying to get property of non-object in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 111

    Notice: Undefined index: layout in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 126

    What should I try next? Would uninstalling the plugin & reinstalling it make any difference, do you think?

    I’m away for a couple of weeks from tomorrow, and it looks like this may not be resolved before I go.

    Thanks for your help & patience so far.

    Plugin Author Jeremy O’Connell

    (@cyberws)

    PHP 5.6 is better.

    That 111 error is saying it can’t pull the template. Did you click save on “Settings” link in the Daily Quotes admin panel?

    Thread Starter johodges

    (@johodges)

    Me back again! I decided to delete the plugin, to the phpMyAdmin stuff and then reinstall. After activating, I went into setting and straightaway got this:

    Notice: Undefined index: qid in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/dqa.php on line 144

    Notice: Undefined variable: qtype in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/dqa.php on line 196

    Notice: Undefined variable: qtype in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/dqa.php on line 196

    Notice: Undefined variable: qtype in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/dqa.php on line 196

    Notice: Undefined variable: qtype in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/dqa.php on line 196

    This is before I’ve started adding a new section. Any ideas?

    Thanks in anticipation,

    Jo

    Plugin Author Jeremy O’Connell

    (@cyberws)

    These notices should disappear in the next version as the code has been altered.

    However they are just notices and don’t prevent the plugin from working. To display warnings and/or notices is controlled by the settings in server’s php.ini file, local php.ini (some hosts allow this), or web server control files like .htaccess, httpd.conf, nginx.conf, etc.

    Thread Starter johodges

    (@johodges)

    Thanks Jeremy. The notices had disappeared by this morning.

    However, I have just put in all my quotes and the shortcode into a test page, which reads thus:

    Notice: Undefined offset: 0 in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 111

    Notice: Trying to get property of non-object in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 111

    Notice: Undefined index: layout in /var/sites/g/growchiswick.org/public_html/wp-content/plugins/cleverwise-daily-quotes/index.php on line 126

    I’ve checked the plugin – the section with all the quotes (down to no. 366) is still there.

    I think I’m at the point of giving up on this, unless you can help.

    Jo

    Plugin Author Jeremy O’Connell

    (@cyberws)

    I would just make sure you clicked on “Settings” then “Save” in the panel to make sure a default template was inserted into your WordPress.

    If you did that it would take more advanced troubleshooting. Your install isn’t wanting to pull a valid template which is causing issues.

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Cleverwise quotes displaying 3 error messages on homepage instead of quote’ is closed to new replies.