Support » Plugin: Delete Expired Transients » Cleared all transients and option table is still huge… what to do?

  • Resolved sojasoja

    (@sojasoja)


    Hi, first of all thank you for the plugin, it works really nicely and I like the simple interface!

    I actually downloaded this plugin because I cannot add new page, post, image, put product in cart nor adding a comment. I found out that the option table in the database is really big, 1 GB, so I thought I should clean that up.

    I first deleted all the expired transients, there were about 3750 lines left, and the file size remained the same, and I deleted all transients, I logged into SQL and I can see that the transients were deleted effectively, it was down to 970 lines, but the file size was still the same.

    Do you know what could the reason be? how could I reduce the file size? I am really having a big headache because nothing is working… your help would be very much appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author webaware

    (@webaware)

    G’day @sojasoja,

    First: you should confirm that the size of your options table is the problem. Have you looked at your server logs to see what error messages are logged? They should tell you something about why you are having these problems.

    It sounds like your wp_options table uses the MYISAM engine. Having deleted a bunch of rows, it’s still holding the space for them, so you need to run an optimize table on that table. You can do that from phpMyAdmin or from the mysql command line tool.

    https://dev.mysql.com/doc/refman/5.7/en/optimize-table.html

    Here’s a plugin that lets you do that from within WordPress:

    https://wordpress.org/plugins/wp-dbmanager/

    Long term, you’re better off converting your database tables to the InnoDB engine, which doesn’t suffer the same problem. Speak to your host about that.

    cheers,
    Ross

    Hi Ross, thank you very much for your reply.
    Effectively the problems were caused by the size of the option table, because it was 1GB and my host only offer 1.024 GB. This is the error code i got: Warning: Creating default object from empty value in /homepages/…/…/htdocs/clickandbuilds/WordPress/myweb/wp-admin/includes/post.php on line 641

    I cleared all transients but as I said, the total size of the option table was the same. Then I contacted my host and they insisted that I have to eliminate more lines to downsize it… then I tried to optimize table as you suggested, nothing changed… I contacted my host again and they confirmed that since the table was too big, somehow the change can´t be made completely. So they duplicated the latest database and eliminate the other one.

    I will talk to my host about InnoDB, although they said that if I clear the transients from time to time, this shouldnt be a problem again.

    Thank you so much for your help, and again, great plugin!

    Plugin Author webaware

    (@webaware)

    No worries, glad to hear your host helped you get that db under control. With this plugin running, it should keep a lid on those transients and stop it from happening again!

    cheers,
    Ross

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cleared all transients and option table is still huge… what to do?’ is closed to new replies.