WordPress.org

Support

Support » Plugins and Hacks » CleanPrint » [Resolved] CleanPrint doesn't show on my posts/pages

[Resolved] CleanPrint doesn't show on my posts/pages

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author johncadams

    @johncadams

    What version of you running?

    Do you have all the page types enabled (included) in the settings page?

    Can you confirm the cleanprint javascript is being injected into the head of the page in question?

    Plugin Author johncadams

    @johncadams

    I have added a new version 3.1.1 under “Other Versions” that I believe addresses the issue. If you could install it and let me know if you up and running I’ll make it the current version.

    I’ll try it this afternoon and let you know

    Same problem with v3.1.1
    I’m running WP 3.3.2 & Genesis 1.8
    Disabled Google Analytics and WordPress SEO plugins just in case and still no buttons.
    Seems like great plugin, hope it gets fixed, thx!

    Source view w/o GA:

    <!-- CleanPrint Debug
    		logoUrl=http%3A%2F%2Fcache-02.cleanprint.net%2Fmedia%2Flogos%2FDefault.png
    		buttonStyle=Btn_text_small
    		PrintInclude=include
    		PDFInclude=include
    		EmailInclude=include
    		ButtonPlacement=tr
    		HomepageInclude=include
    		FrontpageInclude=include
    		CategoryInclude=include
    		PostsInclude=include
    		PagesInclude=include
    		TagsInclude=include
    		PagesExcludes=
    		GASetting=true
    		page_id:0, home:0, front:0, category:0, single:1, page:0, tag:0
    -->
    
    <script id='cpf_wp' type='text/javascript'>
       function CleanPrint(postId) {
       	CleanPrintPrintHtml(null,postId);
       try { _gaq.push(['_trackEvent', 'CleanPrint', 'Print']); } catch(e) {}
       }
       function CleanEmail(postId) {
       	CleanPrintSendEmail(null,postId);
       try { _gaq.push(['_trackEvent', 'CleanPrint', 'Email']); } catch(e) {}
       }
       function CleanPDF(postId) {
       	CleanPrintGeneratePdf(null,postId);
       try { _gaq.push(['_trackEvent', 'CleanPrint', 'PDF']); } catch(e) {}
       }
    </script>
    <script id='cpf_loader' type='text/javascript' src='http://cache-02.cleanprint.net/cpf/cleanprint?key=wpdefault&logo=http%3A%2F%2Fcache-02.cleanprint.net%2Fmedia%2Flogos%2FDefault.png'></script>
    Plugin Author johncadams

    @johncadams

    Find the line in plug-in:
    if (isset($excludes) && isset($page_id)) {

    and change it to simply and see what happens:
    if (false) {

    That works! Is this a permanent fix?

    Plugin Author johncadams

    @johncadams

    Something in that block of code is falling into the return false statement. The debug output isn’t leading me to the cause and we cannot reproduce it here.

    I’m going to release the plug-in without support for per-page exclusion.

    That works for my needs, thanks again for fix — have a good weekend

    @jhncadams – the 3.1.1 plugin I downloaded this morning and just installed is working fine. I can see the buttons on each page. Thank you for the fix!

    I take that back – it worked fine until I tried to change some settings. Now the buttons are gone.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] CleanPrint doesn't show on my posts/pages’ is closed to new replies.
Skip to toolbar