Support » Plugin: NextGen Gallery Powertags » Cleaner permalinks

  • Resolved ottie

    (@ottie)


    Hi Sardbaba 😉

    Thanks for providing a filter in nextgen. I got it working.
    Just one question: I’d like cleaner permalinks – for the moment it shows the url of the page, followed by:
    ?gallerytag=stairs
    I’ve tried using the /%tag%/%postname%/ and reversed, but nothing changes.
    Any ideas how to drop “?gallerytag=” ?

    Thanks
    Ottie

    http://wordpress.org/extend/plugins/nextgen-gallery-powertags/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author sardbaba

    (@baba_mmx)

    Hi Ottie, you are welcome.

    I took a look at this but I can’t figure it out…

    You have first to enable permalinks in WordPress (using for example %postname%) then on NextGen Gallery (wp-admin/admin.php?page=nggallery-options), checking “Activate permalinks” options. You can also change the gallery slug name changing the “Gallery slug name” input field.

    That creates something like:

    http://www.yoursitename.com/yourpagename/gallery-slug-name/tags/yourtag

    but this doesn’t works very well… seems that
    $nggRewrite->get_permalink (a NextGen Gallery function) under my nggpowertags_GetGalleryTags function returns all the tags with the same slug and the filtering doesn’t works at all, even if I put the right slug in the URL.

    So I think it’s a probably bug into NextGen Gallery and, I’m sorry but, I can’t debug it.

    Hope you take it as is and if you like to help me on development, I’ll really be happy 🙂

    Cheers and happy new year!

    Plugin Author sardbaba

    (@baba_mmx)

    After a good meal at the end of year I got a great desire to solve this problem 🙂
    Try to see if the 1.4 version is good.

    Plugin Author sardbaba

    (@baba_mmx)

    Hi Ottie, I mark this as resolved.
    Feel free to reopen if you got other issues.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cleaner permalinks’ is closed to new replies.