WordPress.org

Support

Support » Plugins and Hacks » Cleaner Gallery » [Resolved] Cleaner Gallery – Linked File (URL) issue?

[Resolved] Cleaner Gallery – Linked File (URL) issue?

  • I’ve been using Cleaner Gallery over a year with no problems and very good results.

    Yesterday, I noticed a really big problem. No matter what settings I change, the file being linked to by my jQuery lightbox (Slimbox) is always the full size version. I’m not sure if it’s being caused by Cleaner Gallery or the WordPress Media Uploader.

    Here’s what I’ve discovered:

    Exhibit A. Cleaner Gallery lists all custom image sizes I’ve created using the add_image_size() function. No matter which size I choose for the file being linked to, the full size image is always being displayed.

    Exhibit B. Standard WordPress galleries have the same issue, unless the file URL is explicitly changed in the media uploader file URL field.

    Exhibit C. The file URL field in the WordPress media uploader doesn’t retain changes made to that field. I tried specifying one of my default sizes – xxx-800×600.jpg (“Large” in this case), then saving. As soon as I saved, the field reverts back to the full size image.

    Apparently, this has been a bug with the media uploader for some time. The issue is listed in WordPress trac here: http://core.trac.wordpress.org/ticket/13429

    Sergey Biryukov uploaded a patch which fixed the Media Upload “Save” issue. If anyone’s listening, this patch really needs to get implemented in core soon!

    Exhibit C. The default WordPress galleries work fine after I change the file url field. Cleaner Gallery does not.

    I hate to point at problems, but it seems like Cleaner Gallery has a bug.. Justin Tadlock codes some really great plugins (and themes) so I’m a bit surprised. But these things have been known to happen. 😉

    Has anyone else seen this? It does say Cleaner Gallery is compatible up to 3.0.1, I’m using 3.0.5 on all sites affected.

    http://wordpress.org/extend/plugins/cleaner-gallery/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Cleaner Gallery – Linked File (URL) issue?’ is closed to new replies.
Skip to toolbar