Support » Fixing WordPress » Classic Editor witching to visual doesn’t work

  • Resolved Björn

    (@ahrndt)


    Hi!

    I am using the classic editor and updated to WP 5.5. (incl. all plugins). Inside the editor, when I switch from VISUAL to TEXT, I cannot scroll anymore. I have to reload the page to make it work. Inside the VISUAL editor, I cannot change link options like “target blank” or “nofollow”. The context window doesn’t appear.

    Greets
    Björn

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi Björn,

    I’ve tested 5.5 with the classic editor provided by the Classic Editor plugin and it scrolls fine for me (tested with a long text).

    As for links: I’m also able to change link options (the context window works for me), although there is no “nofollow” option, is that perhaps something added by a plugin?

    It occurs to me that one of the things that changed in 5.5 is that WordPress no longers includes the jquery-migrate library, so plugins that use it should add it themselves. Plugins for the classic editor commonly use this library, so I wonder if that’s the root issue you’re experiencing? Can you try installing this plugin https://wordpress.org/plugins/enable-jquery-migrate-helper/ and report if that fixes your issues?

    Best,
    Andrés

    Thread Starter Björn

    (@ahrndt)

    Hi Andrés,

    thanks for your help. I installed the plugin an scrolling works as well as the link-settings.

    The plugin reports one warning: /wp-content/plugins/bookingcom-banner-creator/js/bdotcom_bc_admin.js: jQuery.fn.live() is deprecated

    So I’ll try to get in contact with the developers of this plugin.

    Greets
    Björn

    That’s great to hear, Björn.

    Now that the issue is fixed, can I ask you to also do a little experiment? I’d suggest deactivating all plugins (including the jquery-migrate), then activating them one by one to test which plugin introduces the errors. Once you have identified it, would you mind contacting the plugin’s author so they’re aware and can update it?

    Best,
    Andrés

    Thread Starter Björn

    (@ahrndt)

    Hi Andrés,

    I think I located the plugin: it is the Ultimate Nofollow Plugin from https://wordpress.org/support/users/5fifty/

    But I cannot reach the developers site – maybe the stopped developing? I try to find another Plugin which offers the possibility to insert nofollow-links to a post.

    Greets
    Björn

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Classic Editor witching to visual doesn’t work’ is closed to new replies.