Support » Plugin: qTranslate X » Classic Editor plugin

  • Resolved jannik1953

    (@jannik1953)


    From WordPress 5.0, a Classic Editor is supplied, as an official WordPress plugin which will be developed and supported at least until 2022 (sic!), according to the description.

    I have just updated my WordPress installation on a website where I do not use qtranslate-x, so that I now use WP 5.0.1 and Classic Editor on that site. The editor looks exactly as it used to do, but I am reluctant to try it out on my main website where I am dependent on qtranslate-x.

    Does anyone have experience with WP 5.0, Classic Editor and qtranslate-x? If it works, it could at least serve as an intermediate solution before migratíng to another multi-language-site plugin.

    • This topic was modified 7 months ago by  jannik1953.
Viewing 6 replies - 1 through 6 (of 6 total)
  • wilfried1954

    (@wilfried1954)

    I have one site with qtranslate-x. It does work withe wordpress 5 if you install the classic editor first.

    jannik1953

    (@jannik1953)

    Thanks for your quick response. Do you mean install Classic Editor before qtranslate-x? If it only works on this condition, it would be of no help since I have used qtranslate-x on this site for years.

    wilfried1954

    (@wilfried1954)

    Hi Jannik,

    No I had qtranslate-x installed on that site for a long time. So Classic Editor is installed after qtranslate-x in my case.

    jannik1953

    (@jannik1953)

    Hi Wilfried,
    Thanks – that is good to hear, since I am in a similar situation. Then I can venture to update my WP as well.

    kalitat

    (@kalitat)

    Hi, i ve just updated to wordpress last version, blocks and some change in editing modes. It is not simple to translate with qtranslate, flags are dissapeared, so all it must be edited handly. We are working in a regency theme for a year to start our project 2019 January 7, and we must finish some posts and retouch some pages. We are very …. about this. Do you know what we can do or what will you do in next days about compatibility between wordpress and qtranslate?

    thanks

    jannik1953

    (@jannik1953)

    I will probably not do anything until sometime in January, as I have not yet updated to WP 5.0. I get the impression that you are using the new standard editor, also called Gutenberg – is that so? If so, I would download and activate the “Classic Editor” plugin instead. It at least looks exactly like the well-know editor from earlier versions.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Classic Editor plugin’ is closed to new replies.