Support » Plugin: Classic Editor » Classic Editor not working with WP 5.3

  • Resolved webgirlie

    (@webgirlie)


    My websites are down with this error message immediately after upgrading to WP 5.3.

    Warning: Declaration of WPDI_Plugin_Installer_Skin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /home1/**mysite**/public_html/wp-content/plugins/classic-editor-addon/vendor/afragen/wp-dependency-installer/wp-dependency-installer.php on line 526

    With 5+ million installs, will you be issuing an update today?

    Or can you offer a solution so I can login to the cPanel and update a file?

    Fingers are crossed.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Thread Starter webgirlie

    (@webgirlie)

    ********

    Many apologies Classic Editor Team!

    I discovered WP 5.3 installed a competitor’s plugin and removed the links for me to access your Classic Editor plugin.

    I removed both plugins to solve the issue.

    Next I put Classic Editor back in the plugins folder, refreshed, and all is back to normal – excellent!

    BTW on their page on this site, the Classic Editor Addon developers make comments against Classic Editor which I felt uncomfortable reading.

    ********

    So happy I stumbled upon this post! I’m currently experiencing this exact same problem. Would you mind sharing the details of which plugins were causing the issue and how you corrected it? Thank you!!!

    Rachel

    Thread Starter webgirlie

    (@webgirlie)

    Hey Rachel, go delete Classic Editor Addon which was added to your site automatically with the update today.

    Best of luck!

    Same here. If you have plugins that access the WP editor then you will probably have issues. So for instance if you have Woo Commerce Social Login you might get this error:
    Warning: session_start(): Cannot start session when headers already sent in /home/sitewpde/public_html/healthyjean.com/wp-content/plugins/woo-social-login/woo-social-login.php on line 811

    I use Mai LifeStyle Pro. It is not thier fault in the least, but since it adds buttons and other items to the editor I get the following errors:
    Warning: Declaration of WPDI_Plugin_Installer_Skin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /home/sitewpde/public_html/healthyjean.com/wp-content/themes/mai-lifestyle-pro/includes/dependencies/wp-dependency-installer.php on line 434

    AND

    Warning: Cannot modify header information – headers already sent by (output started at /home/sitewpde/public_html/healthyjean.com/wp-content/themes/mai-lifestyle-pro/includes/dependencies/wp-dependency-installer.php:434) in /home/sitewpde/public_html/healthyjean.com/wp-includes/functions.php on line 5946

    Simply go in and deactivate whatever plugins are causing the issue along with the classic editor and then activate them again. That worked for me!

    Hey Jean, Mike from Mai Theme here. You’re getting the same error as the OP because our theme and the classic editor add-on seem to rely on the same dependency installer. We have a fix for the theme error by updating our Mai Theme Engine plugin to the latest (v1.10.4.1 at the time of posting this). That should fix it for you. Feel free to ping us via https://support.bizbudding.com if you need anything else.

    There is still a problem with classic editor.
    I use it alongside with yoast and Prosodie VG Wort.
    Both Plugins don’t work with classic editor anymore since WP 5.3.
    At Yoast you can’t edit meta description anymore (nor even see it) and Prosodia does not show the tickerbox for activating a counting mark 🙁

    We’re using Classic Editor and Add-on on our Genesis sites and ran into the same issues described here.

    First, thanks to everybody for your helpful contributions.

    The trick of uninstalling Classic Editor and Classic Editor Add-on got rid of the first error message. We then reinstalled but now have had to deactive Classic Editor add-on to remove string of unwanted text (error code) across the top of page.

    For now, discontinuing ALL site upgrades to WP 5.3 until we learn this is resolved.

    Plugin Author Andrew Ozz

    (@azaozz)

    Hi @webgirlie, thanks for the bug report 🙂

    You’re right. This seems to be a problem in the “Classic Editor Addon” plugin, nothing to do with the Classic Editor plugin.

    I discovered WP 5.3 installed a competitor’s plugin and removed the links for me to access your Classic Editor plugin.

    That’s not possible! WordPress doesn’t do this kind of things 🙂

    Perhaps the Classic Editor Addon was installed by your theme or another plugin you updated? I’d really want to hear about it if you find which one is it. Seems like a pretty bad idea to force plugins on users, especially when they are buggy 🙁

    BTW on their page on this site, the Classic Editor Addon developers make comments against Classic Editor which I felt uncomfortable reading.

    Yeah, plugin authors have a lot of “powers” including the power to promote their plugin as they see fit. I agree, in this case it doesn’t sound good at all. At the end of the day it is up to the users to decide if they want to not have choice…

    Or can you offer a solution so I can login to the cPanel and update a file?

    Sure, it is all in the error message: /wp-content/plugins/classic-editor-addon/....

    I’m glad you managed to fix this by removing the Classic Editor Addon plugin. In similar cases you can log in cPanel and rename the offending plugin’s folder. That will automatically disable the plugin.

    Plugin Author Andrew Ozz

    (@azaozz)

    @jeffseaver As far as I see the problem is in the “Classic Editor Addon” plugin which is a completely different plugin and has nothing to do with the “Classic Editor” plugin in terms of keeping it updated/working and support.

    Seems that disabling or uninstalling the “Classic Editor Addon” plugin fixes the problem?

    Hey Mike! Yes, I hope that I made it clear that it is by no means an issue with your theme and awesome add-ons. Just giving an example error message.

    We have changed over many of our sites to use Mai and your extensions. No need for a page builder when we have you guys! Thanks for chiming in and thanks as always for the super fast and awesome support.

    Hello,

    I removed my classic editor plugin files via cpanel and still am getting the error message. I cannot login to wp-admin.

    Help?

    Thank you.

    Hey @darmarose here are the best solutions when you have issues logging in https://wordpress.org/support/article/login-trouble/. One of those solutions should work. I would start with this one since you are having a plugin issue:
    Disable Plugins #Disable Plugins
    Some WordPress Plugins may interfere with the login process. Disable all of your WordPress Plugins, either through the Administration Screen or by removing them from the /wp-content/plugins/ folder, so they will not be recognized by the program.

    Alternatively, you can rename the plugins folder to something else temporarily to something like

    /wp-content/pluginsXX/ and they will not be recognized. Rename the folder back to /wp-content/plugins/ once the base WordPress installation has been recovered.

    When we’ve seen this issue the /wp-admin/ link whitescreens but you are still able to login by directly visiting the login url example.com/wp-login.php. Note the wp-login.php instead wp-admin. Hope that helps.

    I have had the opposite problem. WordPress 5.3 will not save or publish posts for me without the Classic Editor enabled. (No other editor plugins were enabled, and enabling other plugins one by one did not allow me to publish. As soon as I reactivated the Classic Editor plugin, posts would publish again.)

    Btw, my site works just fine with the “Classic Editor Addon” plugin enabled. So I doubt that is the problem. Activating the Classic Editor Plugin turned the save and Publish functions back on.

    There is the chance that the Classic Editor Plugin has code left behind, even after deactivation, that messes with the Save and Publish functions. (That’s the way it seems to me now.)

    Otoh, it’s possible that the behavior of the plugins is different now than it was when the original post was created …

    • This reply was modified 1 year, 5 months ago by inge12.
Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Classic Editor not working with WP 5.3’ is closed to new replies.