Support » Plugin: Classic Editor » Classic Editor is blank in WordPress 5.0

  • Resolved thepoorswiss

    (@thepoorswiss)


    Hi,

    I forgot about 5.0 and let WordPress update automatically 🙁
    I cannot bear the new editor. So I directly installed Classic Editor, but now the editor is totally blank. If select the text, I can see the text in HTML.

    What can I do ?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    So I directly installed Classic Editor, but now the editor is totally blank.

    Try clearing your browser’s cache, cookies and on your webserver such as from a plugin. Caching has been an issue with some 5.0 upgrades and that may be interfering with you using this plugin too.

    thepoorswiss

    (@thepoorswiss)

    Thanks for your quick answer.

    I tried clearing the cache and cookies and tried disabled my caching plugin as well. I also tried incognito mode.

    Unfortunately, nothing did it.

    sandhofer

    (@sandhofer)

    It is not even blank with me. It is not there at all. If I try to switch from block-editor to classic editor, all I get is the block-editor. I did clear cache and cookies. Same thing. I definitely need the classic editor.

    thepoorswiss

    (@thepoorswiss)

    I found the error for me 🙂

    There was a 403 error for loading tinymce.php stuff in includes/js/tinymce. However, I had a .htacess to deny that! I changed the .htacess and it works now.

    I am guessing that you load this file dynamically? I had installed this based on a security plugin. I am guessing that I may not be the same.

    Elliot Condon

    (@elliotcondon)

    Also experiencing the same issue.

    When editing an ACF field group (a CPT), the following error is thrown and a WSOD is displayed.

    
    
    [06-Dec-2018 21:59:50 UTC] PHP Notice:  edit_form_after_title is <strong>deprecated</strong> since version 5.0.0! Use block_editor_meta_box_hidden_fields instead. This action is still supported in the classic editor, but is deprecated in the block editor. in /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-includes/functions.php on line 4112
    [06-Dec-2018 21:59:50 UTC] PHP Stack trace:
    [06-Dec-2018 21:59:50 UTC] PHP   1. {main}() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/post.php:0
    [06-Dec-2018 21:59:50 UTC] PHP   2. include() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/post.php:160
    [06-Dec-2018 21:59:50 UTC] PHP   3. the_block_editor_meta_boxes() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/edit-form-blocks.php:405
    [06-Dec-2018 21:59:50 UTC] PHP   4. the_block_editor_meta_box_post_form_hidden_fields() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/includes/post.php:2066
    [06-Dec-2018 21:59:50 UTC] PHP   5. do_action_deprecated() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/includes/post.php:2205
    [06-Dec-2018 21:59:50 UTC] PHP   6. _deprecated_hook() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-includes/plugin.php:629
    [06-Dec-2018 21:59:50 UTC] PHP   7. trigger_error() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-includes/functions.php:4112
    [06-Dec-2018 21:59:50 UTC] PHP Notice:  edit_form_advanced is <strong>deprecated</strong> since version 5.0.0! Use block_editor_meta_box_hidden_fields instead. This action is still supported in the classic editor, but is deprecated in the block editor. in /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-includes/functions.php on line 4112
    [06-Dec-2018 21:59:50 UTC] PHP Stack trace:
    [06-Dec-2018 21:59:50 UTC] PHP   1. {main}() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/post.php:0
    [06-Dec-2018 21:59:50 UTC] PHP   2. include() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/post.php:160
    [06-Dec-2018 21:59:50 UTC] PHP   3. the_block_editor_meta_boxes() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/edit-form-blocks.php:405
    [06-Dec-2018 21:59:50 UTC] PHP   4. the_block_editor_meta_box_post_form_hidden_fields() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/includes/post.php:2066
    [06-Dec-2018 21:59:50 UTC] PHP   5. do_action_deprecated() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-admin/includes/post.php:2205
    [06-Dec-2018 21:59:50 UTC] PHP   6. _deprecated_hook() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-includes/plugin.php:629
    [06-Dec-2018 21:59:50 UTC] PHP   7. trigger_error() /Users/elliotcondon/Dropbox/Work/Sites/acf5/wp-includes/functions.php:4112
    
    Plugin Author Andrew Ozz

    (@azaozz)

    @elliotcondon installing Classic Editor 1.0 and setting it to “classic” and preventing users from switching editors should bring the old Edit Post screen with TinyMCE for everybody. That should fix the above error until ACF is updated.

    Elliot Condon

    (@elliotcondon)

    @azaozz Thanks for the reply. I’ve just tried this and can confirm it works. Can you explain a little more about the “Allow users to switch editors” setting and why ACF is tripping up causing a WSOD?

    Also, is this something I need to look at fixing from my side, or is this something in the Classic Editor plugin affecting all CPT?

    Plugin Author Andrew Ozz

    (@azaozz)

    ACF is probably trying to load something on the edit_form_after_title action that doesn’t work any more for the Block Editor. I’m sure that will be fixed soon.

    The “Allow users to switch editors” lets users choose which editor to use for each post. If ACF + Block Editor throws a fatal error, you won’t want to enable it at all.

    Elliot Condon

    (@elliotcondon)

    Yes, we are using the edit_form_after_title action to output some custom HTML.

    Gutenberg does allow this action, although, it parses it through regex to only extract hidden input fields. I don’t yet understand why this error is being thrown and why a WSOD is necessary.

    Is this error coming from WP5.0 or the Classic Editor plugin?

    Elliot Condon

    (@elliotcondon)

    @azaozz Could you please test the Classic Editor plugin with ACF 5.7.7?
    I’m currently testing, but don’t yet understand the WSOD.

    The PHP error is not fatal, and only appears when Classic Editor is active (WP 5.0 + ACF 5.7.7 works correctly).

    Viewing the source code of the page, everything exists. I will continue to test.

    Elliot Condon

    (@elliotcondon)

    Upon further inspection, it seems that when Classic Editor is active, editing an ACF CPT incorrectly loads the “Block Editor”. Can you please help shed some light on why this is occurring?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    That is a notice. Turn off notices and indeed the display_errors setting on your site.

    Deprecated notices are not new, and when you get them, then your code should be adjusted to stop using those.

    Also, please don’t post in other people’s unrelated threads in the future. This has nothing to do with the original topic, so I’m closing this to avoid continually emailing this poor swiss gentleman with updates.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Classic Editor is blank in WordPress 5.0’ is closed to new replies.