Broken Link Checker
class="broken_link" not work link custom fields (5 posts)

  1. seregawaw
    Posted 2 years ago #

    Hello, how to make that a plug-in I crossed out broken links on all site, now works only for links added in the record text, but doesn't work for links removed in arbitrary field.


  2. eliot.eshelman
    Posted 2 years ago #

    I'm also having this issue. After entering the names of my custom fields in the BLC admin panel, BLC does find broken links in those custom fields.

    However, it does not correctly determine the URL which is broken (when visiting the "View Broken Links" admin menu. It also fails to style the URLs as broken on the page (via CSS).

    As an example, let's say I have a broken link in a custom field on this page:

    The custom field has a value of:

    <li>Test broken <a href="http://www.example.com/404-error-no-exist-testing">link</a></li>

    On the "View Broken Links" page, the broken URL is reported as:

  3. seregawaw
    Posted 2 years ago #

    eliot.eshelman, Just add the name of any field in your plugin settings Look For Links In > Custom fields | Configure

  4. eliot.eshelman
    Posted 2 years ago #

    That's exactly what I did. BLC is checking the custom fields, but is not reporting the broken links correctly (just as you describe).

  5. eliot.eshelman
    Posted 2 years ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Broken Link Checker
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.