Support » Plugin: Class Blogs » ClassBlogs_Plugins_Aggregation_Schemata

  • Hi
    gives an error when I click “Activate”/Network Activate .

    wp 3.4.2
    php 5.33
    Mysql 5.1.6
    Apache 2.2.15

    I’ve tried wp 3.3.2 same error

    how can i fix it?
    Thanks for help

    Fatal error: Class ‘ClassBlogs_Plugins_Aggregation_Schemata’ not found in /TPU/htdocs/wordpress/wp-content/plugins/class-blogs/ClassBlogs/Plugins/Aggregation/Aggregator.php on line 494

    http://wordpress.org/extend/plugins/class-blogs/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author oberlincilc

    (@oberlincilc)

    Sorry that the plugin is playing hard-to-get. I’m unable to replicate this error on my end, so I don’t have much to offer besides questions.

    First of all, what operating system are you running?

    Second, since you’re talking about network activation, I assume you’re running WordPress in multisite mode. Have you tried creating a new, test instance of WordPress that’s not running in multisite mode and installing the plugin on that? If so, did you get the same error?

    I wish I had more to offer, but that’s all I’ve got for the moment. I’ll keep playing around to see if I can replicate the error, and roll out a fix if I can.

    I’m getting exactly the same error (the “Aggregation”) one.
    I’m running WordPress Multisite, fully up-to-date (3.4.2).
    Everything on the system appears to work fine, except “class blogging”.
    This is a real shame as I’m doing this for real as a pilot project at a UK academic institution, and “class blogging” looked to do a lot of what we wanted it to..
    If I can provide any helpful info, please ask. Likewise, I’m happy to tinker with the system if you can think of anything to try.

    (I can’t give you a URL for the system as it’s internal-only.)

    Plugin Author oberlincilc

    (@oberlincilc)

    I’m sorry that the plugin doesn’t seem to be working. Clearly there’s a bug that I need to fix if you’re having the exact same error as another user. The problem is still that I cannot seem to replicate this on either my development machine or our production server. In an effort to change this, though, I’ve got a few questions.

    What operating system are you running? What other plugins are you running? Have you tried creating a clean installation of WordPress and only installing the class blogging plugin? Have you tried creating a new, non-multisite installation of WordPress and installing the plugin? If you’re trying out the plugin on a server, have you tried it out on a local, development machine and experienced the same error?

    Hopefully the answer to one of the questions will help me figure out what’s going on. If it doesn’t, we could move this conversation to email and try some much more specific fixes that involve editing the plugin’s source.

    OS is Redhat Linux, Apache Webserver.
    Wordpress is 3.4.2, Multisite enabled.
    Plugins: WPMU LDAP Authentication, Multisite User Management, Multisite Sitelist Shortcode, Breadcrumb Trail, Collapse Page & Category, Custome Meta Widget, Sky Login Redirect, Backupbuddy, WordPress Database Backup, and one of my own (disabling it doesn’t help)

    I’ll see if I can make it work elsewhere on a plain-vanilla WP installation.

    Update: The plugin installs fine on my test system (on external hosting platform, but again Linux, Apache)
    This is a non-multisite installation, so only limited functionality.
    So it’s either a problem with multisite or some quirky of the platform..

    Next test: upgrade my test system to multisite and try it again..

    Plugin Author oberlincilc

    (@oberlincilc)

    Thanks for your system information and the debugging update. When I get some free time, I’ll try replicating a setup with the plugins that you have installed (on multisite and standard installations) to see if that has something to do with it. Based on the outcome of the upgrade of your test system to multisite, perhaps there will be other courses of action that make sense.

    Right. Done that.
    Class Blogs works on my test (multisite) system.
    So it’s not that, then..

    I am seeing the same exact error message on an install of the Class Blogs plugin.

    WP 3.5.1 multi-site
    RedHat Enterprise Linux 6
    Apache 2.0

    I have not had a chance to test this on a single user install or a standard out of box install.

    Plugins active:
    Akismet
    Login Security Solution
    Multisite User Management
    nRelate Related Content
    Ultimate TinyMCE

    Would appreciate any follow up as this sounds like a perfect system for my class needs.

    Plugin Author oberlincilc

    (@oberlincilc)

    Sadly, I don’t have anything new to offer besides the suggestions in this thread, since I still can’t replicate this error on my setup, and don’t have much free time to do any further debugging.

    I’m not sure if you’re still working on developing this plugin, but it sounds like a great solution for our k-12 institution but I unfortunately got the same error message. First on our 3.4.2 multisite, so we created another clean installation for testing of 3.5.1 (also multisite) and same error. Deactivated all of the plugins and still got the error.

    Nagaraj

    (@nagrajsuligavi)

    Hello,

    It’s really great plugin.
    Has anybody found the solution ?
    I am getting same error.

    Thanks
    Nagaraj

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘ClassBlogs_Plugins_Aggregation_Schemata’ is closed to new replies.